Internal Server Error


#1

Ok so I did my homework prior to posting this message and can’t seem to find anybody who has had this exact same problem surprisingly enough.

Anyway I am using Fedora Core 3, and have installed Nagios Version 2.0b3. I am using this system for nothing else at all. Only for Nagios.

I did Nagios install as root.

I followed the instructions to a tee! Spent whole day dedicated to making sure I didn’t miss a step. I also used the GZIPed package and not the RPM package for Nagios and the Nagios plugins.

My problem is I get the Nagios home page fine, and the documentation page fine, but all other links down the left side from “Tactical Overview” through “View Config” all give me the following browser error… (Actually there are a few pages that give me a CGI not found error, but I figured I deal with those later….)


Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

And then in my Apache error.log I get the following error…


[Date][error] [client IP] (13) Permission denied: exec of ‘/usr/local/nagios/sbin/status.cgi’ failed, referrer: 192.168.1.119/nagios/side.html

[Date][error] [client IP] Premature end of script headers: status.cgi, referer: 192.168.1.119/nagios/side.html

I have tried both with and without authentication flag set.
I have tried with and without the default user name options set.
And finally I have tried with setting auth on all folders CGI and HTML via the .htaccess file.

I’m at a total loss. Any ideas?

-Adam


#2

SOLVED:
issues.apache.org/bugzilla/show_bug.cgi?id=33504


#3

Glad you had an easier time finding the answer than I did!!! I’m unsure why this problem isn’t documented more often. Congrats on finding the solution so quickly adoti, it took me a few weeks!


#4

Probably because the nagios docs are not about to explain the details of every app that could possibly be written to secure a website or local filesystem. Those that choose to use such tools, should have read the documention for those tools. I fail to see how we here in this forum, and those that wrote the nagios docs, are supposed to be mindreaders and know exactly what you are using, and how you configured it, and what you forgot to do. When using selinux, I’m sure nagios, won’t be the only install that you perform, that will require you to make adjustments, from the standard install indicated in the docs.


#5

cgi interface gives error permission denird in status
.cgi and premuture execution of script