Internal server error


#1

i changed the OS version from red hat9 to redhat AS ,
i’m going to install nagios 1.2 on this new OS,
i added required lines to httpd.conf file but i 've get " internal server error "
these lines are written in errorlog file of web server :

" permission denied : exec of '/usr/local/nagios/sbin/status.cgi ’ failed …" .
it means it can’t execute cgi scripts?
would you guide me ?
:frowning:

nagios 1.2 worked well on redhat 9 .


#2

what i added to httpd.conf are these :

for CGIs :
ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin/
<Directory “/usr/local/nagios/sbin/”>
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all

and for html :

Alias /nagios/ /usr/local/nagios/share/
<Directory “/usr/local/nagios/share”>
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all


#3

wow,the nagios works well now !

:o
it was related to SELinux , because some thing like ’ avc : denied {execute}… ’ was logged in /var/log/messages file .
the problem was solved by making disable SELinux in /etc/selinux/config (SELinux=disable).