Issue with 2.0b3


#1

I’ve been running Nagios v1.2 on another FreeBSD box and for the most part it’s been running smoothly, minus the occassional “oh my god everything is down! (when it’s not)” issue that I’ve been having. With the same version of FreeBSD installed (4.9), but with Nagios v2.0b3 running, I’m having issues with the reports being sent to me properly. Here’s what an e-mail coming to me looks like:

***** Nagios *****

Notification Type: RECOVERY

Service: SMTP
Host: Mail Server #3 (xyz)
Address: 123.45.67.89
State: OK

Date/Time: $ <-- Problem #1

Additional Info: $ <-- Problem #2

As you can see, the last two variables aren’t being filled - just “$” is present. This works fine on the other system, but for some reason it’s not working on this new server running 2.0b3. Even running nagios as root hasn’t fixed the issue, so I don’t believe it’s a permissions issue. The checking of the services works fine, and is accurate, it’s just not reporting the data completely.

Any help on this would be appreciated. Thank you.

Dustin


#2

some variables changed name if you used your old 1.2 config files that’s probably the problem :slight_smile:

Luca


#3

I am now using the samples for 2.0b3, and using the localhost tests I made a sevice go into an alarm state… and since it wasn’t sending me notifications, I tried to send an acknowledgement that I know the service is down, which worked and sent me an e-mail, but as the comment it just has “$” as the comment. Anyone actually running 2.0b3 with notifications being filled properly?


#4

Try sending yourself the same type of email, by using the syntax found in your config files for notify-by-email command. It might just be that your command definition is not correct, or that as lucas has pointed out, the variables are now different. But I suspect, that you have found just one more reason to stick with 1.2 until all of these bugs are worked out.