Las check in host details


#1

Hey

Im from Brazil, and I need a help.
im using nagios 2.10 on redhat 4.0
when i access the web interface, when i click in the Host Details in the column last check its not updating the date and time. Just updating the localhost.
the service pin is OK, when i do ps -ef | grep nagios i see the service OK.
Its just dont updating the column.
If i click in Service Details, i can see all OK and the last check OK too for all servers.
please, can anyone help me?
and more… if i click in the host, and Enable checks of all services on this host, appear this message:
Sorry Dave, I can’t let you do that…

It seems that you have chosen to not use the authentication functionality of the CGIs.

I don’t want to be personally responsible for what may happen as a result of allowing unauthorized users to issue commands to Nagios,so you’ll have to disable this safeguard if you are really stubborn and want to invite trouble.

Read the section on CGI authentication in the HTML documentation to learn how you can enable authentication and why you should want to.


#2

Hi!

ok; it seems you have 2 different issues:

  1. the first one, about the last check in host details. That’s normal: in fact, (by default) nagios doesn’t check the status of the host, unless one of its service goes down. So, if everything is OK, your hosts will never be checked (unless you turn on :http://nagios.sourceforge.net/docs/2_0/configmain.html#use_agressive_host_checking)

  2. you should have a look at you cgi.cfg file; the comments are clear enough to understand how it works, and what you should change to enable this functionality.
    However, don’t hesitate to ask if you have difficulties :slight_smile:

Hope this helped you ^^


#3

nice i will try…

i post later.

tanksss a lottt


#4

hey… its dont work…
In Host Details, column last check, just host that update the date and time is the localhost. I change the line use… to 1… and nothing happened.
tell me… why just localhost update?
tks again…