'Make Install' Freezes/Hangs


#1

I am running SUSE 10.1 and have tried installing both Nagios 2.5 and 2x.

When I run the ./configure, everything seems fine, run 'make all with no errors, start the ‘make install’ and take off running, until about line 5300 and some and then it freezes, the HD sits and thinks while I lose any control with both mouse and keyboard. Eventually the OS reboots, and it seems as though nothing has gone through correctly.

There are only 2 things that I can see that **might **be creating an issue, but I don’t think they are the answer. One is in the ./configure i get ‘Embedded Perl: No’, but researching I can’t find anything supporting or contending the need for this.

The other is that I get a cannot make temporary file error for the the sample-config files because ‘no such file or directory’ exists. I know the directory does, but do I have to move it? Currently the /sample-config directory lives in my Nagios-2-x-cvs folder.

Also, I do not see the *.cfg files with the number extensions specified. (i.e. cgi.cfg.22552.V22553, but there is a cgi.cfg file) Do I really have to have these for the Install/config? My understanding is they are just that, samples.

Me thinks I’m cursed

TIA!


#2

I still think you have a bad pc. Try to compile and install nagios on another box.


#3

Yeah, I’m thinking you are right. (Both times !lol) after speculating over the water cooler we decided to give another box a go. I will keep you posted on the outcome.