Monitor Solaris box



I have a solaris server that I need to monitor. I have Nagios insalled on RHEL 4.

Do I have to install nagios on Solaris too ?? Is it possible for me to install it on Solaris ? Is there a installer for Solaris ?

In case there is no installer for Solaris, how do i get to monitor Solaris, is it goin to be based on SNMP or is there any other way to do this ?

Thanks !!


Sounds like you have installed your nagios server on Red Hat Enterprise Linux 4.

I know for a fact that nagios (server) 2.9 runs fine on Solaris 9 (SPARC) because I have built and configured it for monitoring the production environment at my work and I have to say that it has been running flawlessly. However, you have to build it from the source, there is no compiled distributed (rightly so).

If what you want to do is just monitor the Solaris system, you can use nrpe for this purpose which can be obtained from the nagios downloads URL at:


you can install nrpe and the plugins on solaris, and monitor them from your RHEL box. It works wonderfully.

You can find already compiled packages for solaris on the net.




thanks for the reply.

I have solaris 10 with me, I couldnt find a suitable NRPE so i installed NRPE 1.9.
After installation I ran

bash-3.00$ ./check_nrpe -H localhost
NRPE v1.9

but when I ran :-

bash-3.00$ ./check_nrpe -H localhost -c check_users
NRPE: Unable to read output
bash-3.00$ ./check_nrpe -H localhost -c check_load
NRPE: Unable to read output

How can I resolve this ??



did you define the commands check_users and check_load in the nrpe.cfg file?
Is the nrpe daemon running?



Hi Aivan,

Thanks for the reply, I realised my mistake.

The solaris box is on the other side of a firewall and I am using the default ports suggested 5666.
Is it going to be a problem if I change these port numbers !!



I never tried to change ports, but should be OK, as long as you change them on both sides, of course.



The solaris box is running Solaris 10.
The nrpe version is 1.9.

bash-3.00$ ./check_nrpe -H localhost
NRPE v1.9

Nagios is on RHEL 4 with NRPE version 2.8.1

[root@HSCHNETLTPK0001 libexec]# ./check_nrpe -H localhost
NRPE v2.8.1

I am able to run check_nrpe with command locally on the solaris host.

bash-3.00$ ./check_nrpe -H localhost -c check_load
OK - load average: 0.02, 0.01, 0.00

But when I run this from the RHEL server to solaris I am getting the error :

[root@HSCHNETLTPK0001 libexec]# ./check_nrpe -H -t 20
CHECK_NRPE: Error - Could not complete SSL handshake.

i ran the nrpe configuration with --disable-ssl and re did the same command with another error. :frowning:

[root@HSCHNETLTPK0001 libexec]# ./check_nrpe -H -t 20
CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.

The Error log says :

Aug 29 15:32:09 emcqa nrpe[17198]: [ID 421412 daemon.error] Could not read request from client, bailing out…

Please help !!


I never got the --disable-ssl to work. Try adding a -n to the startup of nrpe and also make sure to use -n on your command. ./check_nrpe -h -n … or it will still try to use ssl.


you have two different major releases of nrpe running, I think that thte communication protocol has changed in between… try to update nrpe on the Solaris box.



Hi Ivan,

I have 1.9 installed on my Solaris server and 2.8 on my Linux server.
I couldn’t find a higher version of NRPE for Solaris neither could i find the NRPE 1.9 in tarball format for Linux. Is installing with RPM the same ??


sorry I was carried away by the package name (nrpe is version 2 eve n on the solaris bo:evil:.

The RHEL box is mentioned in the allowed_hosts parameter in nrpe.cfg?

No other ideas for the moment, I am afraid…




Since the operating system of the system you are monitoring (Solaris 10) is different than the system where the nagios server is running (RHEL 4), you will have to build the same version of nrpe on both systems.

check_nrpe is used on the nagios server to communicate with the nrpe process on your Solaris 10 system.

On the nagios server, commands.cfg must include the correct port that you have declared in nrpe.cfg on the Solaris 10 system. If it is going through a firewall, the firewall rule must be in place to allow two-way communication between the two systems over that port.

In addition, in the nrpe.cfg on the Solaris 10 system, the allowed_hosts parameter must include the IP address of the nagios server or it won’t work.

I hope that helps. Reply if you’ve got any questions on this.


Hi Aivan

Even i am also facing the same errorwhat amadeus is facing i am trying for this for last one month still iam getting CHECK_NRPE: Error - Could not complete SSL handshake.
i am requesting you guys to share the configuration how you did it in solaris mine is both solaris 10 and solaris9




In your “checkcommands.cfg”, try inserting a “-n” as the first parameter after the “check_nrpe” on the command line.
This will disable the use of SSL.



I was monitoring this issue which i am facing now if i use -n in command it is getting output.but if i tried through browser and try to monitor the disk or users ther it is show “CHECK_NRPE: Socket timeout after 10 seconds.” error could any one ca help me on this…



I was monitoring this issue which i am facing now if i use -n in command it is getting output.but if i tried through browser and try to monitor the disk or users ther it is show “CHECK_NRPE: Socket timeout after 10 seconds.” error could any one ca help me on this…

Please find the attached file …