Monitoring ran into error


#1

hello
I have installed nrpe client on another linux
the following displayed when I clicked on the Service Detail


Host Service Status Status Information

mylinux check_disk CRITICAL CHECK_NRPE:
Error - Could not
complete SSL handshake


why?
by the way,why cannot I open this forum for the time being?
thank you!


#2

The nrpe docs say the client is installed on the central nagios server and the daemon is installed on the remote machine. That’s why you can’t complete a handshake, since there is no daemon running on the remote machine. Read the README again, it will explain exactly how to setup nrpe.


#3

ok,thank you,I’ll try it againg!


#4

oops,
Edited Mon Aug 08 2005, 06:28AM ]


#5

My detail configuration for nrpe on remote host are as follows:
[root@localhost nrpe-2.0]# ./configure
[root@localhost nrpe-2.0]# make all
[root@localhost nrpe-2.0]# cp src/nrpe /usr/local/nagios/
[root@localhost nrpe-2.0]# cp nrpe.cfg /usr/local/nagios/
[root@localhost nrpe-2.0]# mkdir /usr/local/nagios/libexec
Copy these plugins( check_disk check_load check_procs check_users)from /usr/local/nagios/libexec directory on nagios server to /usr/local/nagios/libexec/ directory on the remote host
Add nrpe 5666/tcp # NRPE to /etc/services
vi /etc/xinetd.d/nrpe

default: on

    # description: NRPE
    service nrpe
    {
            flags           = REUSE
            socket_type     = stream
            wait            = no
            user            = nagios
            server          = /usr/local/nagios/nrpe
            server_args     = -c /usr/local/nagios/nrpe.cfg --inetd
            log_on_failure  += USERID
            disable         = no
            only_from       = 192.168.250.238 #my nagios server IP address
    }

The following are configurations on nagios server
The following lines are added to /usr/local/nagios/etc/checkcommands.cfg on nagios server
define command{
command_name check_nrpe
command_line $USER1$/check_nrpe -H $HOSTADDRESS$ -c $ARG1$
}
The following lines are added to /usr/local/naigos/etc/hosts.cfg on nagios server
define host{
host_name mylinux
alias mytestlinux
address 192.168.250.230
max_check_attempts 5
check_period 24x7
contact_groups network-admin
notification_interval 30
notification_period 24x7
notification_options d,u,r
}
The following lines are add ed to /usr/local/nagios/etc/services.cfg on nagios server
define host{
host_name mylinux
alias mytestlinux
address 192.168.250.230
max_check_attempts 5
check_period 24x7
contact_groups network-admin
notification_interval 30
notification_period 24x7
notification_options d,u,r
}


I have installed nrpe according to REDEAD
but now the situation is as mentioned earlier
the following displayed when I clicked on the Service Detail


Host Service Status Status Information

mylinux check_disk CRITICAL CHECK_NRPE:
Error - Could not
complete SSL handshake


confused!

Minquan


#6

it is ok after i changed the mode of nrpe.cfg using command of chmod 777 nrpe.cfg!