Mysql-5 + nagios-1.2 excessive logging


my mysql log (bin) files grow to OVER 1GB! per DAY! (exculsive from nagios)
is there any way to either kill this habit or at least restrict what is getting logged?

i am thinking it is a mysql logging setting, but have been unable to come up with anything as of yet…


(btw…i really do not care for the layout of these forums…hard to navigate, no search and clashing color scheme…)


did you change something recently? 1Gb seems you are logging everything and you must have LOTS of checks running…



i have changed nothing (recently). i figued this out because i ran out of space on my 200GB drive!

where is the logging verbosity for mysql-5 set? any idea?

(thanks for the fast reply!)


is the DB growing or is it a problem connected with the mysql .bin files?

i seem to remember you can reduce the log dimension and rotation on startup using some options… you’ll need to check on the mysql manual…



I suspect you have your binary loggin turned on. If you are NOT running a master/slave replication setup, then simply turn off binary loggin. I had this problem, since I was using replication and needed it. So I had no choice but to run a script to make sure that replication was up to date, and then manually delete the binary log files that where not needed any longer.