Nagios 1.3 on Suse SLES 9


#1

Hi,

Newby to Nagios (and largely Linu:evil: but I am determined to get this working !

I have installed the Nagios packages that come as part of the distro / updates for SLES 9.

These are:
nagios 1.2-73.1
nagios-nsca 2.4-207.1
nagios-plugins 1.3.1-270.3
nagios-plugins-extras 1.3.1-270.1
nagios-www 1.2-73.1

I think my main problems are the different paths that SuSe install to…means the standard docs don’t match what I have :frowning:

James Ogley’s blog (rubberturnip.org.uk) helped make the web interface accessible…

In /etc/sysconfig/apache2 I modded the conf file to include …

APACHE_CONF_INCLUDE_DIRS="/etc/apache2/conf.d/nagios.conf"

Let SysConfig run and after an Apache restart I can get the web pages.

I have tried folllowing the instructions for the authentication (including creating .htaccess), but I still don’t get prompted to login on the web pages.

The Nagios webpages show me logged in as “?” and I am not authorised to view any data. The web pages themselves do appear.

Anyone written a how-to for Nagios on SUSE ???

All help appreciated… :frowning:

Regards
Ian


#2

I would have thought that the yast install of nagios would modify the apache config? If not then what’s the point, just install if from the latest source.


#3

Have you created the password file that the .htaccess files will refer to when you try to authenticate into the web interface?


#4

You can either figure out why the rpm installs didn’t work out of the box or you can install from source and follow the complete and precise instructions. You call. But it appears that your nagios.conf in the apache setup may not be correct, or you haven’t restarted apache, or you have file permission problems, since it states you are user ?. Since you are not prompted at all, I suspect your nagios.conf apache file is not setup right. Compare it to the docs and modify it approprately for your setup.


#5

JF1980,

I creates the Apache config - but it doesn’t set it up as an “include” in Apache2.

I have done that though. :frowning:

SonOfThunder,

Yep - I have the .htaccess files (one for CGI, one for html pages) and I ran the Apache2 util to create the accounts.

I have just received some notes on specific setup on SuSe. Will try these out and report back !!

Thanks !

Ian


#6

Let us know, but if it doesn’t work out, you’d probably end up saving much time (and frustration) by just installing from source. As awesome as I think SuSe is, this would be my recommendation.


#7

did you disable Secure Linux?

Luca


#8

Yes, it was the mods to the apache conf that were wrong.

They actually cover setting up Nagios on SuSe in the Novell SLES course. I was able to obtain a copy of the class exercise which got my basic config working.

I now have it happily monitoring Linux (of course), Netware disks and Directory Services, our SMTP server, printers and more !

Very cool so far - well I have some more files to hack. Http proxy is next I think. :frowning:

Thanks everyone - you have another convert !

Ian