Nagios 2.0b1 Installation Error


#1

Hi, I am newbie and trying to install the nagios 2.0b1 in my debian sarge box.
I have download the tar ball file and untar it to proceed installation, I run through
the ./configure, make all, make install, make install-init, make install-commadmode when I run make install-config, it occur error on install the contactgroups.cfg-sample, error message show no file found in the sample-config>template-object directory. I have checked the md5sum number match after download. I wonder why it happens?

“/usr/bin/install: cannot stat `sample-config/template-object/contactgroups.cfg’: No such file or directory
make: *** [install-config] Error 1”

Because of lacking the sample configuration file, then I write from scratch from nagios online documentation, Unfortunately, I try to run /usr/local/nagios/bin/nagios -v /etc/nagios.cfg, after the pre-check process, it show me there is a error on

“Checking services…
Error: Service check command ‘check_stmp’ specified in service ‘check smtp’ for host ‘smtp.rhs.net’ not defined anywhere!”

Now I am facing the main problem to start up the nagios daemon due to error foremention. :cry: I really wonder where is my mistake, your help is appreciated and thank you in anticipation…


#2

Hi,

I have the same problem.
"/usr/bin/install: cannot stat `sample-config/template-object/contactgroups.cfg’: No such file or directory
make: *** [install-config] Error 1"

Try to install Nagios on Fedora Redhat Core II


#3

Hi ProdaCom,

Does nagios install on Fedora Redhat Core have no problem? Are you using rpm? Is all addon already in? Such as statusmap.cgi …


#4

Anyone find a answer to this as am having the same problem.


#5

hi @ll,
same problem here. trying to install on suse 9.1. everything runs fine but getting make: *** [install-config] Error 1 while proceeding the final step of installation. any ideas whtas wrong ?? bug or feature ??

tia for any hints

greets

sY


#6

hi @ll,

just sorted out, that using the csv-tarball does not causing the errors. so give the 2.x (CVS) Newest Version-Link on nagios HP a try :slight_smile:

have a nice day

sY


#7

I found out the solution…

“/usr/bin/install: cannot stat `sample-config/template-object/contactgroups.cfg’: No such file or directory
make: *** [install-config] Error 1”

Solution: downlaod the nagios 1.x and copy those missing files to the nagios 2.x then solve the problem…


#8

I had the following problem. Its same as someone else’s.

emplate-object/checkcommands.cfg /usr/local/nagios/etc/checkco
mmands.cfg-sample
/usr/bin/install -c -m 664 -o nagios -g nagios sample-config/t

emplate-object/contactgroups.cfg /usr/local/nagios/etc/contact
groups.cfg-sample
/usr/bin/install: cannot stat `sample-config/template-object/c

ontactgroups.cfg’: No such file or directory
make: *** [install-config] Error 1 ////ERROR LINE
[[email protected] nagios-2.0b1]#

And someone else suggested me the following solution:
(As far as i could see, the Makefile has some old entries. You can copy
the config manually to your …/etc directory. The config files are in
located in the sample-config/template… dirs.)

Then I did this, I guess it worked fine. As I manually copied the config files to /etc directory.

But then I had another problem in Installation of the plugins.
Its as follows;

Plugin installation problem

I am trying to install Nagios plug ins from the following file.
nagios-plugins-1.4-beta1.tar.gz

During installation it properly executes and finishes ./ configure
command. Now, when i try this “make all”. It gives me the following
error after doing a considerable processing.

gcc -g -O2 -L. -o check_real check_real.o netutils.o utils.o …/lib/libnagios
plug.a …/lib/libcoreutils.a -lnsl -lresolv -I/usr/include
if gcc -DLOCALEDIR="/usr/local/nagios/share/locale" -DHAVE_CONFIG_H -I. -I. -I
… -I… -I…/lib -I…/intl -g -O2 -MT check_smtp.o -MD -MP -MF “.deps/check_
smtp.Tpo” -c -o check_smtp.o check_smtp.c;
then mv -f “.deps/check_smtp.Tpo” “.deps/check_smtp.Po”; else rm -f “.deps/check
_smtp.Tpo”; exit 1; fi
gcc -g -O2 -L. -o check_smtp check_smtp.o netutils.o utils.o …/lib/libnagios
plug.a …/lib/libcoreutils.a -lnsl -lresolv -I/usr/include
check_smtp.o(.text+0x777): In function process_arguments': /home/gopi/useless/nagios-plugins-1.4-beta1/plugins/check_smtp.c:456: undefined reference toterminate’
collect2: ld returned 1 exit status
make[2]: *** [check_smtp] Error 1
make[2]: Leaving directory /home/gopi/useless/nagios-plugins-1.4-beta1/plugins' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory/home/gopi/useless/nagios-plugins-1.4-beta1’
make: *** [all] Error 2

Could anyone please suggest solution to this.

Thanks
kaushal

Edited Sat Jan 08 2005, 06:13AM ]


#9

The answer is to grab the files from the 1.2 installation of Nagios and copy them into the template config directory and then do make install config again.

The second error is a typo on your part. check_stmp <> check_smtp