Nagios 3.03 install on Fedora9


#1

I followed the quick start instructions on how to get Nagios up and running however when I run the chkconfig command to install Nagios as a service I get the following error:
error reading information on service nagios: No such file or directory

I’ve received no errors anywhere else that I am aware of? How do I rectify this and be able to start Nagios as a service?


#2

Are you sure you’re using the correct syntax of a command?
Pls, type here exactly what you are typing in order to receive this error.


#3

Thanks for the response.

The command I’m using is:
chkconfig --add nagios

The error message immediately comes up. I’m also doing this because the quick setup for Fedora shows this as a command to run to get it working as a service.


#4

Are you in directory where nagios executable is? If not, try to cd to directory containing nagios executable file.


#5

I tried it from the executable directory and get the same result. At the moment that directory is:
/usr/local/nagios/bin


#6

Hm, tough one. :slight_smile:
Did the installation create the nagios file in init.d folder. Check in /etc/init.d/ and search for nagios file. If not, I would recommend doing the installation all over again. Maybe you have just forgot to do the command
make install-init
or some of commands necessary for the installation.
I’m guessing blindly now, so…


#7

Actually the “make install-init” part was missing from the original install. Thanks for your help. :slight_smile: