Nagios 3.06 Died upgraded to 3.1.0


#1

I have had nagios installed since the 1.x days with minimal issues, but I left on Friday, nagios was up and running! I get into the office to realize that nagios is not running I run the command service nagios checkconfig eveything looks ok so I start it with service nagios start and get Starting nagios: done.
I check the log file and get
[1234887556] Nagios 3.1.0 starting… (PID=8277)
[1234887556] Local time is Tue Feb 17 10:19:16 CST 2009
[1234887556] LOG VERSION: 2.0
Which is normal, but if I do a ps -A |grep nagios nothing nagios.lock shows the pid same as the log. Any ideas on this
Thanks in advance

Rusty


#2

additional info Ihave gathered about this issue
te: 2009-02-17 23:58:27 GMT (15 hours and 18 minutes ago)

I checked disk space df -h  all had  20gb or more space wise, and then sudo to the acct  and ran the following:

[nagios dprmisnag572 var]$ /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
[nagios dprmisnag572 var]$ ps -A |grep nagios
11916 ? 00:00:00 nagios
11919 ? 00:00:00 nagios
11926 ? 00:00:00 nagios
11933 ? 00:00:00 nagios
11940 ? 00:00:00 nagio s
11947 ? 00:00:00 nagios
11954 ? 00:00:00 nagios
11961 ? 00:00:00 nagios
11968 ? 00:00:00 nagios
11975 ? 00:00:00 nagios
11982 ? 00:00:00 nagios
11989 ? 00:00:00 nagios
11996 ? 00:00:00 nagios
12066 ? 00:00:00 nagios
12187 ? 00:00:00 nagios
12333 ? 00:00:00 nagios
12334 ? 00:00:00 nagios
[nagios dprmisnag572 var]$ ps -A |grep nagios
nothing returned
then it dies with the foloowing in the nagios.log file
[1234914856] Nagios 3.0.6 starting… (PID=11915)
[1234914856] Local time is Tue Feb 17 17:54:16 CST 2009
[1234914856] LOG VERSION: 2.0
[1234914856] Warning: Host ‘HVFSMTL01’ has no services associated with it!
[1234914856] Warning: Host ‘MTSD0029’ has no services associated with it!
[1234914856] Warning: Host ‘MTSD0031’ has no services associated with it!
[1234914856] Warning: Host ‘MTSD0032’ has no services associated with it!
[1234914856] Warning: Host ‘dfwftp’ has no services associated with it!
[1234914856] Finished daemonizing… (New PID=11916)
[1234914856] HOST DOWNTIME ALERT: clovertech;STARTED; Host has entered a period of scheduled downtime