Nagios access and configuration


#1

I have now manage somehow to run naigos, but have some problems.
A like to access nagios over the web, but cannot.
If u put in cgi.cfg
default_user_name=guest

than everybody can access to nagios, I don’t want that.
So I did this
Example: authorized_for_system_information=nagiosadmin,theboss
Example: authorized_for_system_commands=nagiosadmin
Example: authorized_for_configuration_information=nagiosadmin
Example: authorized_for_all_hosts=nagiosadmin,theboss
Example: authorized_for_all_host_commands=nagiosadmin
Example: authorized_for_all_services=nagiosadmin,theboss
Example: authorized_for_all_service_commands=nagiosadmin

and

First, create a file called .htaccess in the /usr/local/share/nagios/cgi-bin directory.

so I dn’t have this directory cgi-bin
so I did that in directory /nagios/share
and
completely, you can also put a copy of the same file in the /usr/local/share/nagios directory.
again don’t have this directory and I putted file in /nagios/share
Put the following in this .htaccess file.

AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/share/htpasswd.users
require valid-user

and

htpasswd -c /usr/local/nagios/share/htpasswd.users bob
New password: ******
Re-type new password: ******
Adding password for user bob

I notice that I don’t have this directory
cgi-bin
/usr/local/share/nagios/cgi-bin

And still doesn’t work even If I have all users setup.

And when i use guest access, so anybody can see nagios, I did this just for testing I found 2 things.
first there is some error
localhost - Total Processes - UNKNOWN 16-06-2006 14:44:29 0d 1h 41m 6s 4/4 check_procs: Unknown argument - (null)

How to get rid of this unknown error.

and next when I click
Servicegroup Summary I get this
There are no service groups defined.

I didn’t find where to setup those groups and how!
:evil:


#2

Run
make all
again on your source of nagios.
Notice this time,that is says you can run many other makes,
make install"
@echo " - This installs the main program, CGIs, and HTML files"
@echo “”
@echo " make install-init"
@echo " - This installs the init script in $(DESTDIR)$(INIT_DIR)"
@echo “”
@echo " make install-commandmode"
@echo " - This installs and configures permissions on the"
@echo " directory for holding the external command file"
@echo “”
@echo " make install-config"
@echo " - This installs SAMPLE config files in $(DESTDIR)$(CFGDIR)"
@echo " You’ll have to modify these sample files before you can"
@echo " use Nagios. Read the HTML documentation for more info"
@echo " on doing this. Pay particular attention to the docs on"
@echo " object configuration files, as they determine what/how"
@echo " things get monitored!"

So, run those also.
You are NOT supposed to have a nagios/cgi-bin directory. If you follow the nagios docs, you will read what directories you are supposed to have.
It also sounds like you might have ran ./configure --sbindir set to something you made up yourself. Don’t do that. About all you need to specify is this perhaps.
./configure --with-command-group=nagcmd --enable-embedded-perl --with-perlcache
So, start all over from the begiinning, and read the docs and follow them.