Nagios active checks are not working, service/host status &#


#1

Hello
I installed Nagios, and configured it as per instructions Nagios.cfg, cgi.cfg, hosts, hostgroup, services, checkcommands, resources etc.

When I verify the configuration using Nagios –v, its not showing any error.

So, I can get web interface, authentication and I can see the hosts and services in Nagios.
But problem is Nagios is not checking hosts/services on its own, means active host or service check is not running. Active service checks are ON in Nagios.cfg. It shows the host/service status as ‘pending’.
In status field I get the massage ‘this service/host has not yet been checked’
Though active checks are enabled, plug-ins and commands are proper and Nagios is running as daemon.

What I have to do to solve this???
:?:


#2

I haven’t quite figured out why, but even though you can have notification’s enabled, checks, enabled, etc, in your config files, nagios hasn’t quite gotten that through it’s head yet. Soooo, click on the “Disable checks of all services on this host” and then “check-mark” the box for “the host too” and hit “commit”. Now go back and repeat, but this time, enable checks. It should update and check in about 5 min or so.


#3

I tried this solution but active checks are still not working. My active checks are returning value null.
I have checked all the permission on the files. They seem to be correct.
Configuration check returns no errors.
Please reply ASAP as my production environment is getting affected due to this.


#4

If a check returns value null it IS working…