Nagios dont send alerts of passive checks: SOLVED


#1

Hi,

I have installed Nagios 2.10 in RedHat 5, all works fine. Nagios checks all things that I need it.
But passive check, that I use to monitoring host with snmp, dont send me alerts mails.
I have checked the configuration of services and host, and the notifications are enabled.
The notifications for active checks works fine.
In the logfile when an alert appear, I can see this:

[28-02-2008 15:52:50] SERVICE NOTIFICATION: admin_mail;3GServer;3GB02 HTTP;CRITICAL;notify-by-mail;Conexin rehusada
Service Critical
[28-02-2008 15:52:50] SERVICE ALERT: 3GServer;3GB02 HTTP;CRITICAL;HARD;3;Conexi


#2

Hi!

well, sorry but no: I can’t help you :slight_smile:

could you post extracts from your config files ? maybe it could give us some clues on what the issue comes from :slight_smile:

btw: in your nagios web interface, are the passive check in critical state ? (ie: do your passive checks receive their status ?)


#3

This is an extract of .cfg file

define service{
use snmp-generico
service_description B2BUA
host_name IVPController
max_check_attempts 10
notification_interval 60
notification_period 24x7
notification_options r,w,c,u
contact_groups admins_grupo
}

The service are OK, or WARNING or CRITICAL, depending of the snmp traps that Nagios receives. In this moment the services changes the state.
In the web interface I see:

Passive Checks: ENABLED
Notifications: ENABLED

In all my passive services.


#4

The problem is solved.
The problem was: max_check_attempts
When I config this with 1, the problem Disappeared.

Thank you for all

:smiley: