Nagios Forum Search broken?


#1

Every time I try to do a search I get the following:

[quote]The following words in your search query were ignored because they are too common words: email from send.
You must specify at least one word to search for. Each word must consist of at least 3 characters and must not contain more than 14 characters excluding wildcards.
[/quote]

As you can see I’m within the boundaries of the “must consist of” statement. I’ve tried longer words, but everything comes back with this failure.


#2

My guess is your search query was email from send, right? Well, as it mentions all of those words will be ignored because they are too common. Since there are no other words left, you get the You must specify at least one word to search for… reply as well.

You can test it by searching for email from send consist instead. That search will get a result. 8)


#3

Unfortunately that doesn’t do myself much good. My initial searches were “configure email from”, also same problems… too common, and that’s exactly what I want to reference.

I’m trying to figure out if nagios has a way to change who the “from” sender is to pass through one of my customer’s filters. It must come from a specific user with a specific domain. I’ve fixed it through sendmail masquerading to force the domain only in the email from address, but unless I re-install nagios with the specified account (which is a dummy account on RedHat) I haven’t been able to get it to send it out as that user.

Example:
Compiled and installed as nagios, emails typically go out as: nagios@hostname.domain.
With masquerading through sendmail, can make it: nagios@domain

To make it go out with the dummy account I’ve had to either reconfigure nagios, remake, & reinstall with that dummy account, or modify the /etc/init.d/nagios user and group, take ownership of /usr/local/nagios with the dummy account with exception of /usr/local/nagios/rw which must be dummy.nagcmd, and finally modify the /usr/local/nagios/etc/nagios.cfg’s user and group.

Either way, painful solutions that I would hope there is an easier option to get the same results.
To have the from email be: dummy@domain

However, I can’t search for it on this forum. Grrr.