Nagios main screen not showing


#1

Hi all, I just installed Nagios 2.9 on a fresh installation of Fedora Core 6, then copied my old .cfg files from our old server (running nagios 1.2) to the new one. I read the ‘sticky’ thread by jakkedup about documention errors, corrected all of those, and ran /usr/local/nagios2/bin/nagios -v /usr/local/nagios2/etc/nagios.cfg until it came back with no errors, and thought everything was good. When I go to the URL, it askes for my userid and password, then brings me to the Home screen. The menu bar is in the left frame and it has all the normal links. The right frame shows Nagios Copyright © 1999… Version2.9, April 10, 2007, etc,etc,etc.

When I click on a link “Hostgroup Overview” it comes back with:

[blockquote]Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.


Apache/2.2.4 (Fedora) Server at netmon1 Port 80[/blockquote]

Either that, or it just shows a blank page.

Hopefully someone can point me in the direction I need to look at. I know I havn’t supplied all the info you guys need to troubleshoot this, just ask away and I will reply giving you all the details I can.

Thanks!
Ray

P.S. When I run as root
[blockquote] /etc/init.d/nagios start[/blockquote]
it just says
[blockquote]Starting nagios: done.[/blockquote]


#2

More info I thought of. Here are two sections from my httpd.conf file since this looks to be maybe httpd related…

[blockquote]ScriptAlias /nagios2/cgi-bin/ /usr/local/nagios2/sbin/
<Directory “/usr/local/nagios2/sbin/”>
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios2/etc/htpasswd.users
Require valid-user

[/blockquote]

[blockquote]Alias /nagios2/ /usr/local/nagios2/share/

<Directory “/usr/local/nagios2/share/”>
Options None
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios2/etc/htpasswd.users
Require valid-user

[/blockquote]

Hope this helps!
Thanks,
Ray


#3

I figured it out. I had the Alias ahead of the Script Alias in the httpd.conf. I don’t know why that mattered, but when I put the Script alias settings ahead of the Alias settings it worked. Just wanted to let others know in case they messed it up like I did.