Nagios NRPE


#1

Hi everbybody! ))
I have some troubles using nrpe addon for nagios.
all changes in my config-files are “copy-paste” from the README file.
in checkcommands.cfg:

define command {
command_name check_nrpe
command_line /usr/local/nagion/libexec/check_nrpe -H $HOSTADDRESS$ -c $ARG1$
}

in services.cfg:

define service {
use generic-service
host_name gate

check_command check_nrpe!check_chk
}

where check_chk is simple check_ping with my args to ping remote office.

if i run in shell:

./check_nrpe -H ip -c check_chk

it returns

PING OK - Packet loss = 0%, RTA = 2.03 ms

but nagios show me this CRITICAL message:

(Return code of 127 is out of bounds - plugin may be missing)

what i made wrong?

P.S. Nagios 2.0b3, FreeBSD 6.0-STABLE
P.P.S. sorry for my terrible english :frowning:
Edited ]


#2

if I correctly remember, I had a similar problem, the reason was the incompatibility between version of check_nrpe and NRPE deamon.


#3

Have you run through the entry in the faq?
nagios.org/faqs/viewfaq.php?faq_id=17


#4

Ha! I’ve got the same error right now :slight_smile: after I added the new command in checkcommands.cfg.
I simply mistyped the script name there.