forums.meulie.net

Nagios Scheduling

Hello all,

Got a query about scheduling the host/services checks. I’ve been through the documentation and configured accordingly to check the services/hosts every minute. But the scheduling queue tells a different story altogether. It’s checking the services once in 5 minutes. These are the configuration parameters that I’ve set.

define service{
use generic-service
host_name Remote_Router
service_description PING
is_volatile 0
check_period 24x7
max_check_attempts 3
normal_check_interval 5
retry_check_interval 1
contact_groups linux-admins
notification_interval 120
notification_period 24x7
notification_options w,u,c,r
check_command check_ping!800.0,20%!900.0,60%
}

even setting normal_check_interval to 1 doesn’t help.

The settings in nagios.cfg file are as follows

command_check_interval=-1
check_external_commands=1
max_host_check_spread=30
max_concurrent_checks=0
service_reaper_frequency=10
auto_reschedule_checks=0
auto_rescheduling_interval=30
auto_rescheduling_window=180

service_check_timeout=60
host_check_timeout=30
event_handler_timeout=30
notification_timeout=30
ocsp_timeout=5
perfdata_timeout=5

retention_update_interval=80

I’ve just copied and pasted what I see in the link scheduling queue page.

   Last Check                  Next Check           Active Checks 

21-12-2005 12:41:55 21-12-2005 12:51:55 ENABLED

So what changes do I need to make so that the checkes are initiated every one minute? Thanks in advance.

Regards

Srid

I hate to ask this, but did you restart nagios after making those changes? Also, check interval_length=xx in your configs. I understand why you were getting your check issue in the first place with having that check interval set to 5. Mayhap you should also check your generic-service template to make sure that earlier on a check interval of 5 isn’t specified. That’s just a guess; I don’t know if Nagios would even run if you specified two different normal_check_intervals for a host.
Edited Wed Dec 21 2005, 05:56PM ]