Nagios status dead? ***SOLVED***


#1

Hello all, long time no see
I am running nagios 1.2. Been running for months with no problems. I made a change to a host config file(not the cause of my problem, but how I discovered it) I restarted nagios and got a “failed” message. When I ran a nagios status, it says "dead"
I ran nagios -v and it came up as clean

Here is how it looks

**Nagios 1.2
Copyright © 1999-2004 Ethan Galstad ([email protected])
Last Modified: 02-02-2004
License: GPL

Reading configuration data…

Running pre-flight check on configuration data…

Checking services…
Checked 59 services.
Checking hosts…
Checked 39 hosts.
Checking host groups…
Checked 11 host groups.
Checking contacts…
Warning: Contact ‘riff-page’ is not a member of any contact groups!
Warning: Contact ‘raff-page’ is not a member of any contact groups!
Checked 4 contacts.
Checking contact groups…
Checked 1 contact groups.
Checking service escalations…
Checked 0 service escalations.
Checking host group escalations…
Checked 0 host group escalations.
Checking service dependencies…
Checked 0 service dependencies.
Checking host escalations…
Checked 0 host escalations.
Checking host dependencies…
Checked 0 host dependencies.
Checking commands…
Checked 30 commands.
Checking time periods…
Checked 4 time periods.
Checking for circular paths between hosts…
Checking for circular service execution dependencies…
Checking global event handlers…
Checking obsessive compulsive service processor command…
Checking misc settings…

Total Warnings: 2
Total Errors: 0

Things look okay - No serious problems were detected during the pre-flight check**

Does anyone know what the problem may be? According to the web interface, everything seems to be working as normal.

EDIT:
I was going to mention that my logs didnt reflect a problem. I double checked to make sure, and this is in my log:

** Error: Could not create external command file ‘/var/spool/nagios/nagios.cmd’ as named pipe: (17) -> File exists. If this file already exists and you are sure that another copy of Nagios is not running, you should delete this file.
[1145296547] Bailing out due to errors encountered while trying to open the external command file for reading… (PID=6814)**

I moved the file nagios.cmd, but still no go :frowning:

EDIT: SOLVED!!
To make a long story short, it was an ownership issue with nagios.cmd