Nagiostat display nothing


#1

Hello all,

I am trying to integrate nagiostat but I won


#2

Have you configured nagiostat.conf?
Waht does debug.log say?


#3

hi,

here is my nagiostat.conf looks like

Pointer to where the rrd-tool binary is located

RRDToolPath /usr/bin/rrdtool

Pointer to where HTML-templates are stored

HTMLTemplatePath /usr/local/nagios/nagiostat/html-templates

Pointer to HTML-template for the index-page (relative to HTMLTemplatePath)

GraphIndexTemplate graphindex.html

Pointer to directory where the RRD-archive-files are stored

nagiostat automatically creates RRD-archives if they dont exist.

IMPORTANT: the whole directory RRDArchivePath must be writable by the nagios user (that calls the

nagiostat-script)

RRDArchivePath /usr/local/nagios/nagiostat/archives

and debug.log is empty. and permission looks like this
-rw-r–r-- 1 nagios nagios 1 Nov 20 03:04 debug.log

And I added in my httpd.conf this
Alias /nagiostat/ /usr/local/nagios/nagiostat/
<Directory /usr/local/nagios/nagiostat>
Options +ExecCGI
Order allow,deny
Allow from all

M


#4

Have you restarted Apache?


#5

Yes, I did re-started both apache and nagios.

One thing is, i tried to test the nagiostat by issuing command as follows :
[root@localt]# ./nagiostat -t
nagiostat: Testing configuration-file…
Thu Nov 20 08:11:59 2008
!!ERROR: RRDTOOLPATH does not point to executable rrdtool-binary.

But I verified that rrdtool executable are in right place and made changes accordingly in nagiostat.conf as follows :

Pointer to where the rrd-tool binary is located

RRDToolPath /usr/bin/rrdtool

I am not sure where I am missing,

M


#6

Check the permissions on rrdtool


#7

okay permission for rrdtool as follows .

-rwxr-xr-x 1 root root 6866 Oct 31 01:36 /usr/bin/rrdtool

is that not sufficient ?