NDOUtils- problems with flushing data


#1

Hello, I recently updated my distro (I used Debian stable and updated to testing) and wanted to switch from Nagios packages (a bit messy, conf files could be found everywhere and are placed illogically).

Everything hone without problems- nagios is up and running, mysql was installed earlier, but it is occupying correct port and running too. But I have problems with forcing NDOUtils to work- i configured it and installed without problems - NDOmod is running with nagios. Still, I get error

ndomod: Could not open data sink! I'll keep trying, but some output may get lost...

I tried deletind ndo.sock and rerunning nagios and ndo2db. config files: ndo2db and ndomod correspond with each other (correct sockets, mysql passwords etc). Strangely- ndo2db, despite turning all debug info, is not writing any information to its ndo2db.debug file…

Nagios and ndo2db are running as services.

I’ve gone through almost every solution on many forums and still haven’t found right one. Could anyone help?


#2

The only idea i get is to check ifyou can correctly connect to the mysql db with the username and password you are using?


#3

Tried logging and:

[code]***********@PLKTWSV008:~$ mysql -u nagios -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 147
Server version: 5.1.49-3 (Debian)

Copyright © 2000, 2010, Oracle and/or its affiliates. All rights reserved.
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL v2 license

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

mysql> use nagios
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql>
[/code]

So it isn’t problem with login/password. I tried to set all passwords/login data etc to “nagios” for now for making simplier to find error…