Needing help configuring Nagios on Ubuntu 8.10


Hi Guys
I am a newbie here and I need some help on configuring nagios 3 onto my server. I get a error message everytime I try to restart nagios 3 its giving me this error:
"Reading configuration data…

Error: Could not open config directory ‘/etc/nagios3/servers’ for reading.

***> One or more problems was encountered while processing the config files…

 Check your configuration file(s) to ensure that they contain valid
 directives and data defintions.  If you are upgrading from a previous
 version of Nagios, you should be aware that some variables/definitions
 may have been removed or modified in this version.  Make sure to read
 the HTML documentation regarding the config files, as well as the
 'Whats New' section to find out what has changed.
  • errors in config!"

I am kinda lost on what this is wanting here.


Hi Tim,

You could have a number of problems here, but my guess would be that your primary configuration file (probably nagios_directory/etc/nagios.cfg) has a directive in it with a bad reference. When I was installing Nagios 3, the build didn’t create all of the necessary directories, and I had to create some of the directories myself. You may also want to check the permissions on that directory to ensure that your nagios user can access the directory. If all of this checks out, you may want to run a verification test on your object configuration files (probably in the nagios_directory/etc/objects/ directory). The verification command should read nagios_directory/bin/nagios -v nagios_directory/etc/nagios.cfg. You can use this to verify your configuration files are properly formatted. Hope this helps.




well I was able to get my nagios back up after restalling ubuntu and nagios. but now I get error: "CRITICAL - Bogus ICMP: Port Unreachable (192.168.x.1). also I need help on setting up my servers to this nagios3 I am using windows server 2003 and a other ubuntu 8.10 and I am planning on adding couple more servers soon and I need help on configuring this. Thanks Tim