New, and looking for some help


#1

Alright guys, im pretty new to doing installs on ubuntu… and so far… i got most of it installed, but now im stuck at

  1. Configure the Web Interface
    Install the Nagios web config file in the Apache conf.d directory.
    make install-webconf
    Create a nagiosadmin account for logging into the Nagios web interface. Remember the password you assign to this account - you’ll need it later.
    htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin
    Restart Apache to make the new settings take effect.
    /etc/init.d/apache2 reload

when i try to run root@sensor-desktop:~/downloads/nagios-plugins-1.4.11# make install-webconf
i get
make: *** No rule to make target `install-webconf’. Stop.

any thoughts on what im doing wrong?


#2

Hmm, not really an Ubuntu man myself, so I can’t help you with that part. But what I can do is suggesting to use a more recent version of Nagios. Version 1.4.11 (assuming you use the same version of both the nagios and the nagios-plugins package) was released over 2 years ago.

Perhaps this quickstart guide and version 3 are the way to go?


#3

whoops… ya i was trying something different when i posted that and got the same error, i have the latest version of nagios 3.0.6 and i get the same error…

any ideas?


#4

[quote=“newb_unix”]whoops… ya i was trying something different when i posted that and got the same error, i have the latest version of nagios 3.0.6 and i get the same error…

any ideas?[/quote]

Which folder are you in when you give the make install-webconf command?


#5

figured id share this as well

rebooted the box, tried again… and this is what i got now.
root@sensor-desktop:~/downloads/nagios-3.0.6# make install-webconf
/usr/bin/install -c -m 644 sample-config/httpd.conf /etc/httpd/conf.d/nagios.conf
/usr/bin/install: cannot create regular file `/etc/httpd/conf.d/nagios.conf’: No such file or directory


#6

My guess is that the folder ‘/etc/httpd/conf.d/’ does not exist…? Is Apache installed in your system?


#7

Ya, its location is /etc/apache2


#8

Hmm, the quickstart guide is based on Ubuntu 6. A bit old… Perhaps Ubuntu has shuffled the locations of its config files since then?
I guess you can get the install to work by symlinking /etc/httpd to /etc/apache2 (but only if your have a /etc/apache2/conf.d folder! If you don’t have that one, then Ubuntu has shuffled more than I can analyze without having an Ubuntu system here…)

The make command should then work without problems… I think… 8)
(any Ubuntu guru’s reading this? Am I making any sense here?)


#9

alright so whats really weird, is it wont let me create a folder under etc… is that normal in unix?? i figured i was a admin, and could do that… and under the apache2 folder there is a conf.d folder, with nothing in it… under the apache2 folder there is a httpd.conf file, but when i try to move it i get permissions denied…

sooo i think this is becoming a permissions issue…

ill be on later… but going home for the day, this is racking my head.


#10

Yup, sounds like you’re not root on that system…

Let’s continue tomorrow. 00:22am here, so time for my… ahem… beauty sleep! 8)


#11

morning everyone,

Any ideas on where i may be stuck at?


#12

just tried to update apache… and got this

Setting up apache2-mpm-worker (2.2.8-1ubuntu0.3) …

  • Starting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
    OK ]
    Setting up apache2 (2.2.8-1ubuntu0.3) …

any thoughts?


#13

[quote=“newb_unix”]morning everyone,

Any ideas on where i may be stuck at?[/quote]

weren’t we stuck at you not being root? 8)


#14

[quote=“newb_unix”]just tried to update apache… and got this

Setting up apache2-mpm-worker (2.2.8-1ubuntu0.3) …

  • Starting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
    OK ]
    Setting up apache2 (2.2.8-1ubuntu0.3) …

any thoughts?[/quote]

That’s just a minor warning. As long as you access that server only within your local net, or via IP, it does not need a FQDN