Newbie setup Issue


#1

Hello All,

I have only recently picked up linux again for a work project involving nagios.

It installed fine and i have it mostly monitoring the host and another machine in test. Will eventually be live monitoring multiple servers.

Anywho, my problem is that after setup everything seems to monitor ok except HTTP and SSH.

I have attached pics of service details screen for both services.

  1. HTTP is giving error -** “HTTP WARNING: HTTP/1.1 403 Forbidden”**
  2. SSH is giving error - “SSH OK - OpenSSH_3.9p1 (protocol 1.99)”

I have seen an number of threads with the same http issue but i don’t understand the resolution.
Gives info to edit parameters, etc… but i don’t know what to edit.

Before yesterday i haven’t used linux in 4 years.

Installing on RHEL4.

Any info would be greatly appreciated.



#2

SSH is OK as I can see.

For HTTP maybe the site is password protected, so yuo should add password as an argument. Go to /etc/nagios-plugins/config directory and there should be .cfg files for each plugin. Edit the http.cfg and see which arguments it needs. You may also try to run the plugin from the terminal and run it with --help switch to see all available options and reconfigure it in the http.cfg to suit your needs. And then when configuring http service, in the check command variable you should put your defined command with arguments in order like this
check_command check_http!argument1!argument2!argument3!..!argumentN
respectively on how much arguments you have defined in http.cfg for your command.


#3

Ok, Thats great. Will test in work tomorrow.


#4

Ok, have had a look at this.

Plugins are not located in Nagios-plugins. This fodler does not exist.

Plugins show in /usr/local/nagios/libexec
Is this a problem. I cannot run check_http when i go into the libexec folder. get command not found error.

I get a response when i put ./ before check_http. Is this right?

Also cannot find a http.cfg file. Any plugin details seem to be under a command.cfg.

Have i totally messed up the installation of the plugins??


#5

Anyone got any advice??


#6

[blockquote]Plugins are not located in Nagios-plugins. This fodler does not exist.
Plugins show in /usr/local/nagios/libexec[/blockquote]Thats more normal… I’m not sure what build process put’s them into nagios-plugins but it’s not current manual build… maybe installing via YUM or APT or something does that… not to worry anyway.

[blockquote]Is this a problem. I cannot run check_http when i go into the libexec folder. get command not found error.

I get a response when i put ./ before check_http. Is this right?[/blockquote]Yes, if you run a command in the libexec directory from the CLI in the libexec directory you’d need to precede it with ./

[blockquote]Also cannot find a http.cfg file. Any plugin details seem to be under a command.cfg.[/blockquote]Yes, that’s the one you want. You need to add the basic auth parameter in your check_http command object - this is the -a switch as can bee seen in the plugin help:

[code][root@localhost libexec]# ./check_http --help
check_http v1861 (nagios-plugins 1.4.11)
Copyright © 1999 Ethan Galstad nagios@nagios.org
Copyright © 1999-2006 Nagios Plugin Development Team
nagiosplug-devel@lists.sourceforge.net

This plugin tests the HTTP service on the specified host. It can test
normal (http) and secure (https) servers, follow redirects, search for
strings and regular expressions, check connection times, and report on
certificate expiration times.

Usage: check_http -H | -I -u ] -p ]
-w ] -c ] -t ] -L]
-a auth] -f <ok | warn | critcal | follow>] -e ]
-s string] -l] -r | -R ] -P string]
-m <min_pg_size>:<max_pg_size>] -4|-6] -N] -M ] -A string]
-k string] -S] -C ] -T ]
NOTE: One or both of -H and -I must be specified

-a, --authorization=AUTH_PAIR
Username:password on sites with basic authentication…
[/code]

[blockquote]Have i totally messed up the installation of the plugins?? [/blockquote]Nope

Shout if you want another clue :wink:

HTH

/S