No output returned from plugin


#1

Hello!

I’m new too with nagios and ihave stuck with this problem…:frowning:

I have installed on a debian router nagios-nrpe-server and i want to check it from my server.
My services configuration file have this settings:

# Check CPU Load
define service{

use generic-service
host_name leonidas.scorp.lwn,hickory.spone.lwn
service_description CPU Load
check_period 24x7
max_check_attempts 3
normal_check_interval 5
retry_check_interval 1
check_command check_nrpe!check_load
}
and the results are
[1200261600] CURRENT SERVICE STATE: leonidas.scorp.lwn;CPU Load;UNKNOWN;HARD;3;(No output returned from plugin) in /var/log/nagios2/nagios.log

however when i try with:
periklis:~# /usr/lib/nagios/plugins/check_nrpe -H leonidas.scorp.lwn -c check_load
the results are ok.
OK - load average: 0.00, 0.00, 0.00|load1=0.000;15.000;30.000;0; load5=0.000;10.000;25.000;0; load15=0.000;5.000;20.000;0;
i’m very sorry for my english…:stuck_out_tongue:
thanks!


#2

Hi!

could you add your command definition for the command “check_nrpe” ? (if it is not the default one).

Also, to help you identify the problem, enable the logging on your routeur:
set “debug=1” in your nrpe.cfg file.
This will log the possible errors in your syslog file. This might help you (or us if you post it here :))


#3

The command definitions are in the file /etc/nagios-plugins/check_nrpe.cfg and are the following:

[code]# this command runs a program $ARG1$ with arguments $ARG2$
define command {
command_name check_nrpe
command_line /usr/lib/nagios/plugins/check_nrpe -H $HOSTADDRESS$ -c $ARG1$ -a $ARG2$
}

this command runs a program $ARG1$ with no arguments

define command {
command_name check_nrpe_1arg
command_line /usr/lib/nagios/plugins/check_nrpe -H $HOSTADDRESS$ -c $ARG1$
}
[/code]

i had already setup debug=1 but i cant find anything from nrpe…:frowning:
thanks again! :slight_smile:


#4

Well, this might be your problem:
you’re using the command “check_nrpe”, which asks the nrpe to be used with an argument, although you don’t have one and you don’t need one.

So, you might try to use your “check_nrpe_1arg” command instead (if you haven’t already).
Also, check in your nrpe.cfg file that your check_load command is expected without any argument.

and, to finish: are you sure there’s nothing in your syslog file about nrpe ? it should log every error nrpe encounters (I don’t know the location of this file under debian, but try /var/adm/messages)

ps: sorry for my english; it’s too early to write something clear :wink: but I hope you understand anyway ^^


#5

Thank you very match!!
The problem is solved!! :D:D

Jan 15 13:59:40 leonidas nrpe[2730]: Connection from 10.128.4.3 port 48041 Jan 15 13:59:40 leonidas nrpe[2730]: Host address is in allowed_hosts Jan 15 13:59:40 leonidas nrpe[2730]: Handling the connection... Jan 15 13:59:40 leonidas nrpe[2730]: Host is asking for command 'check_disk' to be run... Jan 15 13:59:40 leonidas nrpe[2730]: Running command: /usr/lib/nagios/plugins/check_disk -w 20 -c 10 -p /dev/hda1

i changed the command, from check_nrpe to check_nrpe_1arg and it worked succesfully!!
thanks again!