No output returned from plugin


#1

Hello Friends,

By searching a huge information database on the Internet,finally I am asking you to give me solution to configure NRPE for AIX. Please check below steps for detailed information.

  1. Configured Nagios Server 3.0.6 on CentOS 5.2 & it is working fine with normal commands. I am getting localhost “Disk Usage, Memory, Swap Space etc…”

  2. I have 3 nos.of AIX 5.3 OS & all AIX Servers are connected with my CentOS 5.2 in a same LAN Switch. I can ping & ssh locally & i have configured check_ssh , check_ftp , check_http services on my CentOS to monitor AIX Servers.

  3. Now, I though to install NRPE on AIX 5.3,so that I can get better AIX Server Output like … Disk Usage,Swap Usage,CPU Load, Online Users.

  4. For that,i have downloaded AIX compiled patch from below listed URL
    monitoringexchange.org/cgi-b … 9.html;d=1

I have copied all tar files,which i download onto AIX Servers & did all things as mentioned in “howto.txt” file.

  1. All plugins on AIX is working locally.Check below result.

/usr/local/nagios/libexec/check_swap -w 30% -c 10%
SWAP OK - 100% free (41057 MB out of 41472 MB) |swap=41057MB;12441;4147;0;41472

Now, from Nagios Server Side, executing the same command,giving me an error.
./check_nrpe -n -H 10.100.19.86 -c check_swap -t 30
NRPE: Command ‘check_swap’ not defined

  1. On the Nagios Web Interface,i am getting error of :- No output returned from plugin
    Kindly check attached snap1.jpg

  2. I have configured nagios server 3.0.2 & NRPE version 2.12 on AIX,which is tested as per the “nagios exchange” community. Then, why i am getting this error?

  3. Some Command output of AIX PC.(Which is NRPE installed)


ps -ef | grep nrpe
nagios 164070 1 0 17:23:41 - 0:01 /usr/local/nagios/nrpe -c /usr/local/nagios/nrpe.cfg -d

Some Important Command Outputs :-

If I type below command from centos nagios server to aix nrpe client, i am getting below message.

/usr/local/nagios/libexec/check_nrpe -H -c check_load -t 30
CHECK_NRPE: Error - Could not complete SSL handshake.

/usr/local/nagios/libexec/check_nrpe -H -c check_load -t 30 -n
NRPE: Command ‘check_load’ not defined

/usr/local/nagios/libexec/check_nrpe -n -H localhost
CHECK_NRPE: Error receiving data from daemon.

./check_nrpe -H localhost
NRPE v2.12

**telnet 5666
Trying 10.100.19.86…
Connected to gjvatwb1 (10.100.19.86).
Escape character is ‘^]’.

It means, AIX NRPE is working fine???

netstat -at | grep nrpe
tcp 0 0 *:nrpe : LISTEN

telnet 5666
Trying 127.0.0.1
Connected to localhost (127.0.0.1)
Escape character is ‘^]’.

Kindly suggest me what is the solution for this error? I tried my best to find out hundreds of links on the internet,but got nothing.

Advanced Thanks,
Nishith Vyas**


#2

I have configured “nrpe 2.12.tar.gz” plugin on centos as per the documentation provided in the nagios.pdf format.


#3

nagios server’s command.cfg file details.

define command{
command_name check_nrpe
command_line $USER1$/check_nrpe -n -H $HOSTADDRESS$ -w $ARG1$
}

without -n , my nagios server can’t fetch data from aix pc.

**
nagios server’s switch.cfg file details.**

define service{
use generic-service ; Inherit values from a template
host_name gjvatwb1 ; The name of the host the service is associated with
service_description Swap Space ; The service description
check_command check_nrpe!check_swap ; The command used to monitor the service
normal_check_interval 5 ; Check the service every 5 minutes under normal conditions
retry_check_interval 1 ; Re-check the service every minute until its final/hard state is determined
}

Same service configuration for check_disk , check_users & check_load , !!! But, all services are giving same error.


#4

haven’t used NRPE for a long time but it looks like a configuration error of the nrpe deamon on the aix box… could it be you need to define the commands tin the NRPE config file on the AIX side?


#5

Yes. I have installed NRPE compiled plugin for AIX 5.3 & it is tested as per nagiosexchange.com community.

Now, what should i do?

Help Me Out.


#6

Dear Friends,

Any Luck for the error of nagios?