Not able to complete installation on Fedora 9


#1

Hi. I am new to Linux and Nagios. Today I tried to install Nagion on this Fedora box. I could run the commands as mentioned in the Fedora Quick start. However, I am not able to go forwoard from step 5. In the step 5 I am able to run two commands which are

  1. make install-webconf
  2. htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin

But I am not able to run the third command to restart apache to make the new settings take effect.
When I run the command service httpd restart I get thee following message.

**[root@localhost nagios-3.0.6]# service httpd restart
bash: service: command not found
[root@localhost nagios-3.0.6]# **

Since I was not able to run this command I went to step six, which I could complete but again I got stuck in Step 7.
In step 7 when I ran the command
chkconfig --add nagios I got the following message
[root@localhost nagios-plugins-1.4.11]# chkconfig --add nagios
bash: chkconfig: command not found

I then ran this command chkconfig nagios on but got the same messag…
[root@localhost nagios-plugins-1.4.11]# chkconfig nagios on
bash: chkconfig: command not found

Then ran the command service nagios start which gave me the same message as above…

The step 8 first two commands getenforce and setenforce 0 also gives the same message as follows i.e bash: chkconfig: command not found.

I was able to execute the last two commands of step 8 which are…
chcon -R -t httpd_sys_content_t /usr/local/nagios/sbin/
chcon -R -t httpd_sys_content_t /usr/local/nagios/share/

Finally at setp 9 when I typed in localhost/nagios/ I just got the blank page.

Is it due to the reason I am using the higher version on fedora ??? As mentioned in this tutorial that these instructions were written based on a standard Fedora Core 6 Linux distribution.

Any help will much be appreciated.

Neesad.


#2

Try /sbin/service httpd restart, using /sbin/ before the command