Notification by email


#1

hello,
i want to change the mail adress where the notifications are send from [email protected]
to my personnal mail adress.
i made it simple and in the contacts.cfg i put my personnal mail instead of the nagios one, but it does not work.

what do I have to change else?
tks


#2

edit your /etc/passwd file for the user nagios.
Modify or insert whatever you want in the 5th field. i.e.
vi /etc/passwd
nagios:x:502:502:[email protected]:/home/nagios/:/bin/bash


#3

i did edit as u told me,
but i still have one question:
in contacts.cfg file what should I put in the email of “nagios contact definition”?
my personnal mail @ ?


#4

in contacts.cfg you need the email you want the mail sent to…
Alternatively you could put the username of some system user which then gets expanded to an email address byt the /etc/passwd file… (as Jakkedup said above)

Luca
Edited Tue Aug 09 2005, 04:52AM ]


#5

nagios:x:511:511:[email protected]:/home/nagios:/bin/bash

The 5’th filed , display the Full Name , which I inserted , not the Email id , It Changes the Full Name
I thing , he need to change the "mailsettings"
from nagios users command mode , if he gives “mailsetttings” he can view the present settings
He need to change this nagios mail id ,
This is my observation , I google to check how to change the mailsettings for users
, But I did not get it , changing the mailsettings , is the correct answer for his Question
Thanks
Joseph John