Notification Don't work


#1

I can’t get the e-mail notifications on nagios to work. I have set up the correct way via the docs that nagios website have. I tail -f the the nagios.log and see Host alerts and Service alerts. I have purposely failed things to see if the notifcation would be sent out but to no avail it does not work. Can anybody please help :roll:


#2

hi, i have the same situation too. my email address was already defined on contacts.cfg. pls help


#3

Could it be that the actaul linux box is not sending out any email. I’m leaning in that direction.


#4

try this using the commandline

echo ‘test mail’ |mail

if you will be able to receive email then the mail program is running fine.


#5

Do the above test as user nagios also.


#6

Thanks jake I got the email working… it turned out that godaddy.com was blocking the emails. Just used my yahoo account and what do you know it worked just fine


#7

hey, how come my notification still not working. i’m using the nagios account and i was able to receive an email when i execute the above command. pls help


#8

if it works as user nagios, then you most likley have a syntax error in the command definition for “notify-by-email”


#9

do i still need to edit notify-by-email command definition? i was able to send mail using the command /usr/bin/mail -s. pls help


#10

By default, the notify-by-email and host-notify-by-email worked fine for me, but it might be different for your systems. Are you sure you’ve defined the contact e-mail in contacts.cfg and whom needs to be notified of what in services.cfg?


#11

If you can send the alert when doing it by hand, but nagios won’t do it, then you haven’t enabled notifications yet.
Do so, and you will get emails.

nagios.sourceforge.net/docs/1_0/ … ml#service
notifications_enabled=???
And most importantly did you read this yet?
nagios.sourceforge.net/docs/1_0/ … tion_notes
Read it and then enable notifications by using the cgi web interface that has a link that says "Enable notifications for this service"
If you didn’t do that, then it isn’t going to work.
Disable/enable or enable. But you MUST use that link to be sure it’s enabled.


#12

i was just testing the check_ping service but somehow i’m not getting a notification email. pls help


#13

[quote=“jakkedup”]
If you can send the alert when doing it by hand, but nagios won’t do it, then you haven’t enabled notifications yet.
Do so, and you will get emails.

nagios.sourceforge.net/docs/1_0/ … ml#service
notifications_enabled=???
And most importantly did you read this yet?
nagios.sourceforge.net/docs/1_0/ … tion_notes
Read it and then enable notifications by using the cgi web interface that has a link that says "Enable notifications for this service"
If you didn’t do that, then it isn’t going to work.
Disable/enable or enable. But you MUST use that link to be sure it’s enabled.[/quote]


#14

notificatios_enabled=1 and notification for the particular service was already enabled but i still cant receive notification.


#15

Again, read this:
nagios.sourceforge.net/docs/1_0/ … tion_notes
If you aren’t going to read the link, then you have to take my word for it. Or read the link above and understand WHY you must do as I suggested.
Now, PLEASE, clik on the link for enable/disable notifications and toggle it. It doesn’t matter what it says now for the link, enable or disable. You need to toggle it due to the above url.

Edited Fri Jan 13 2006, 08:41PM ]