Notifiing out of timeperiods


#1

Hi,

I have a problem with some monitoriced servers. In my hosts.cfg I have defined all the servers with my notificacion period from 8am to 8pm. The problem is that some servers are ignoring that are still notifiing 24x7. That’s causing a lot of emails in my inbox cause most of servers are shuting down at night to do backups.

Anyone know where can be the problem? Any other cfg file maybe? I really can’t find why is that happening.

Thank you very much.


#2

Have you reloaded Nagios after setting those time periods?
Check the timeperiods.cfg if your time period names are set correctly. Do a config verification to see if there are any errors.


#3

Hi,

as like Alex, i’m having the same issue, this being that time periods defined in timeperiods.cfg or in the hosts.cfg which time period to have effect, are being ignored by Nagios when sending the notification emails. In the hosts.cfg i’ve changed all notification_period fields to “workhours” instead of the preconfigged 24x7.

I even verified the nagios.cfg to make sure there are no other notification_period’s superseding the one in timeperiods or hosts.cfg. Have other people had this issue before as well or not? I’m running out of places to look what could be overriding the timeperiods.

Any help is highly appreciated.


#4

Hi!

I use timeperiods and everything is fine :slight_smile:
but, along the “notification_period” option, I always use the “chec_period” option and set it to the same timeperiod

ex:
define service{
use XRMS-service
host_name XRMS_rim-proactif-sup-01
service_description Log
check_command check_nrpe-2.0p!5667!mon_check_log_xrms
check_period xrms-timeperiod
notification_period xrms-timeperiod
}

for 2 reasons:

  1. to ensure no notifications will be sent (cause nagios won’t do the test, so no worries :))
  2. what’s the point of testing something you know will crash ? :slight_smile: => less checks is always better ^^

Hope this will help you;
if not, post a full definition of what you’re doing (timeperiod def, host def, service def, contact def, contactgroup def, hostgroup def and other that may be usefull)


#5

Hi Loose,

i’ve modified the hosts.cfg and then in the hosts folder all the different .cfg files to reflect this change. So i have check_period on 24x7 and notification_period on workhours. Please find below a small excerpt from those files, because Nagios still keeps sending out notification emails at night, while it shouldn’t do that.

hosts.cfg:

Generic Windows Server Template

define host{
name windows-server
use generic-host
check_period 24x7
check_interval 5
retry_interval 1
max_check_attempts 10
check_command check-host-alive
notification_period workhours
notification_interval 30
notification_options d,r
contact_groups admins
hostgroups allhosts,windows-servers
register 0
}

and here is an excerpt from one of the hosts files:

Host Template Noshferatu

define host{
name Noshferatu
use generic-host
check_period workhours
check_interval 5
retry_interval 2
max_check_attempts 10
check_command check-host-alive
notification_period workhours
notification_interval 720
notification_options d,u,r
contact_groups admins
register 0
}

and yet even with this config and having stopped/started nagios completely, it still won’t accept these changes. Any ideas where it could still go wrong or is this a bug?

thanks


#6

scratch the above message i would say; finally found why nagios kept ignoring the pre-defined timeperiods; was due to one flag hidden in services.cfg …thanks for the help anyhow


#7

Hi Noshferatu,

Having the same problem, what was the flag?