Nrpe check timing out


#1

Hello,

I’m running nrpe version 2.9. I have a script which I wrote a few years ago which checks and reports the openmanage values to Nagios. One of my scripts which checks the voltage is timing out. The script was working fine for months and for a few weeks now it is acting up. This issue is happening on a few servers while others do not see the issue.

What I tried doing to debug the problem is running the check_nrpe locally on a machine that has the issue and it is showing up on that machine as well. When I run the script on the server manually it returns within 2 seconds. Is there anyway to troubleshoot where the issue is?

Thanks in advance,
Nick


#2

You could start with the traceroute from server to host you wish to check and see where is the biggest hop. Maybe it’s some network issue.

Also check the system variables (proc load, mem usage, disk usage etc.) on the remote host to see if there is any overload.


#3

Hi!

Firstly, could you post the exact timeout message you get ?

Also, have you tried to run a “check_nrpe -H host_address” from your nagios server to your monitored computer ?