NRPE - Could not complete SSL handshake


#1

Wow, it seems like this is a common issue but no real definitive solution that I have found so far. So, here is my issue:

Nagios server IP is 192.168.1.5 and the remote server I want to monitor is 192.168.5.15.

Installed NRPE on the remote server using ./configure first, then ./configure --with-ssl=/usr//lib/ too, no luck, same result.

In the the /etc/xinetd.d/nrpe I changed the line to only_from = 192.168.1.5 (this is the IP address of the Nagios server, not the client)

In the file /usr/local/nagios/etc/Nrpe.cfg file I uncommented the line and put server_address=192.168.1.5 (The IP of the Nagios Server)

In the file /usr/local/nagios/etc/Nrpe.cfg file I put allowed_hosts=192.168.1.5 (the IP of the Nagios server)

I added the port, 5666 to the firewall.

I do: netstat -at | grep nrpe
tcp 0 0 *:nrpe : LISTEN

I have restarted xinetd several times, same result when I run sudo /usr/local/nagios/libexec/check_nrpe -H 192.168.1.15 (the IP of the remote server) when I run it FROM the remote server.

Please give me some help. I am new to Linux and need to get Nagios up and running for several servers. It’s been very slow so far…

I appreciate it!


#2

Hi Mackman,

      Even I am having same issue, any how use this command /usr/local/nagios/libexec/check_nrpe -H 192.168.1.15 -n -c "any command".

and let me know what you get.

     -n ignores ssl handshake.

Thanks\Regards,
Khalid Pasha


#3

Ok, I did the command: /usr/local/nagios/libexec/check_nrpe -H 192.168.1.15 -n -c “any command”

And received the following:

CHECK_NRPE: Error receiving data from daemon.

Appreciate any help :slight_smile:


#4

Hi Mackman,

Any Progress in this issue. Even I am struck :roll:  in this issue.

Thanks\Regards,
Khalid Pasha