NRPE not working... very URGENT


#1

Hi,

my solaris server is on RHEL5 , i have installed nagios-plugins-1.4.13 and nrpe-2.12. But when i check NRPE on the remote server(locally) its not working …

bash-3.00# /usr/local/nagios/libexec/check_nrpe -H localhost; tail -f /var/adm/messages
CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.
Oct 8 12:37:58 term-ser inetd[21119]: [ID 702911 daemon.error] Failed to set credentials for the inetd_start method of instance svc:/network/nrpe/tcp:default (chdir: No such file or directory)

I have installed it correctly… but i am unable to understand the logs…

Can ne 1 help me out here …

Thanks


#2

Correction: my nagios server is on RHEL :slight_smile:


#3

did you install xinetd and start the service?


#4

yes… i have done that… please go through …

bash-3.00# inetadm -l svc:/network/nrpe/tcp:default
SCOPE NAME=VALUE
name="nrpe"
endpoint_type=“stream"
proto=“tcp"
isrpc=FALSE
wait=FALSE
exec=”/usr/local/nagios/bin/nrpe -c /usr/local/nagios/etc/nrpe.cfg -i"
arg0=”/usr/local/nagios/bin/nrpe"
user=“nagios"
default bind_addr=”"
default bind_fail_max=-1
default bind_fail_interval=-1
default max_con_rate=-1
default max_copies=-1
default con_rate_offline=-1
default failrate_cnt=40
default failrate_interval=60
default inherit_env=TRUE
default tcp_trace=FALSE
tcp_wrappers=TRUE

bash-3.00# inetconv -e
svc:/network/rpc-100235_1/rpc_ticotsord:default enabled
svc:/network/tftp/udp6:default enabled
svc:/network/rpc-100083_1/rpc_tcp:default enabled
svc:/network/rpc-100068_2-5/rpc_udp:default enabled
svc:/network/nrpe/tcp:default enabled

bash-3.00# svcs svc:/network/nrpe/tcp:default
STATE STIME FMRI
online 12:43:35 svc:/network/nrpe/tcp:default

bash-3.00# netstat -a | grep nrpe
*.nrpe . 0 0 49152 0 LISTEN

How could i check if xinetd is started???

bash-3.00# ps -ef | grep inet
root 217 1 0 Sep 19 ? 3:33 /usr/lib/inet/xntpd
root 25574 24195 0 13:04:01 pts/65 0:00 grep inet
root 24026 1 0 10:59:24 ? 0:08 /usr/lib/inet/inetd start

Thanks 512


#5

i used pkill -HUP inetd to restart the service… please help me out here…


#6

check service xinetd status

Did you check these two things

1.Make sure the nrpe daemon is running under xinetd.
netstat -at | grep nrpe
The output out this command should show something like this:
tcp 0 0 *:nrpe : LISTEN

2.Next, check to make sure the NRPE daemon is functioning properly. To do this, run the check_nrpe plugin that
was installed for testing purposes.
/usr/local/nagios/libexec/check_nrpe -H localhost
You should get a string back that tells you what version of NRPE is installed, like this:
NRPE v2.12

512


#7

Firstly i am on solaris…
so service xinetd status will not work… :frowning:

  1. also netstat -at | grep nrpe will not work…
    bash-3.00# netstat -an| grep 5666
    *.5666 . 0 0 49152 0 LISTEN

  2. bash-3.00# /usr/local/nagios/libexec/check_nrpe -H localhost; tail -f /var/adm/messages
    CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.
    Oct 8 12:37:58 term-ser inetd[21119]: [ID 702911 daemon.error] Failed to set credentials for the inetd_start method of instance svc:/network/nrpe/tcp:default (chdir: No such file or directory)


#8

I am sorry to say that i did not work on solaris with nrpe.

512