NRPE on Solaris 10


#1

Hi.

We are currently running and Nagios on a Redhat Linux host, and NRPE on about 2 two dozen Redhat Linux servers to monitor them. The installation of NRPE on all the Redhat servers went fine.

This week, I’ve trying to get NRPE installed on a Solaris 10 machine and it’s been a nightmare.

Right now, NRPE has finally been compiled and all the plugins work correctly locally.

However, when I try to do a remote check from our Nagios host machine, I can’t get it working. I’ve spent hours trying to figure out what is going wrong, and I can’t figure it out.

From the Nagios host in the libexec directory, I’ve been trying to do a simple server load check on the new machine.

./check_nrpe -H 192.168.55.62 -n -c check_load -a 10,5,2 20,10,5

That same command will retrieve correct info from all 24 redhat machines, but when I run it against the solaris 10 server all I get is :

CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.

I’ve tried looking in the syslog. Either I’m looking in the wrong place or there is absolutely nothing at all in the syslog, despite the fact that I changed the nrpe.cfg setting to let it log things.

Does anyone have any ideas how to get the two machines talking to each other correctly?

Thanks


#2

I am amazed on how many linux boxes you are using nrpe on. For some unknow reason, passive checks on the central sever are ignored by 90% of nagios users. My only suggestion in your case is to get rid of nrpe on at least your Solaris box, and give nsca a try. When you get nsca working on Solaris, then the linux boxes will be easy. After that, you will be 100% passive checks on your central nagios server, and will be able to run 1000’s more checks, that will EVER be possible with ACTIVE NRPE checks.