NSClient and Windows 2003 SP1 issues


#1

So, I can get the NSClient 2.01 up and going on XP and 2000 hosts but when ever I try to get it to go onto a Windows 2003 SP1 (don’t have any non-SP1 machines) I always get the same thing when trying to start the service. Here is the error from the Application Log:

Faulting application pNSClient.exe, version 2.0.1.0, faulting module unknown, version 0.0.0.0, fault address 0x008c2425.

Has anyone seen this? I have Nagios (2.04b) checking all my services great except for my 2003 SP1 servers. The NSClient looks like installs ok, doesn’t throw any errors or anything like that.

Thanks.

phyler


#2

will check tomorrow. i have a 2003 server with nsclient… not sure about SP1… but i think it has it…

Luca


#3

Thanks. It is very strange. I have even tried it on brand new server install but I only have SP1 CD’s so I can’t build a pre-SP1 server.


#4

Just as an FYI, I got a Win2k3 machine up without SP1 and NSClient worked great. Only when SP1 gets applied does it fail.

phyler


#5

checked… 2003 server SP1. and ntclient gave no problems…

Do you have the microsft SNMP service installed? possibly they conflict somehow… no idea…

Luca


#6

Interesting, I did have SNMP installed on that machine. I uninstalled and the problem still remains. But I did get it working on a SP1 machine so SP1 may be red herring but I still can’t get it to work for some reason.

Any other ideas of what could be confilcting?

phyler


#7

Could it be you avtivated teh SP1 integrated windows firewall? I just asked the person who installed the servers and he told me in SP1 there’s an integrated firewall… but it should be disabled by default.

Luca


#8

Yeah, the firewall is disabled.

The strange thing here and this might be another bad path is that the servers it won’t work on are all new Dell servers. Could it be an issue with it running on a certain processor?

I can get it to run on all my older servers with SP1. Did you get your copy of NSclient from the NagiosExchange site? I think it is called pNSClient.exe? Or maybe I’m using a strange one?

Thanks.

phyler


#9

So, more testing. I installed a pre-SP1 version of 2k3 on the same machine that is bombing and it worked fine. It is something to do with the SP1 version of Win2k3 that ships with the Dells.

I don’t know if SP1 is locking something down or if something else is conflicting or what. I can get it to go on machines that started off without SP1 and then were upgraded but if the machine gets installed with the SP1 release of Win2k3 it will not work.

Thanks for looking and thinking about it.

phyler


#10

I found this on the plugin-devel mailing list and it solved my problem:

Found this solution at: pantz.org/blog/.

NSClient will now run as a service on our Windows Server
2003 (SP1) box.

W2k3 Data Execution Protection (DEP) Date/Time: 6-10-2005
9:45 PM EST

I got nailed with windows 2003 server sp1"s new Data
Execution Protection (DEP) (stack protection) today. I was
trying to install the nagios NS Client program on a server
with DEP turned on. When you tried to start the nagios agent
service you would get “System Error 1067 has occurred”.
Which means the process was aborted and windows says “The
process terminated unexpectedly”. To make an exception for
certain programs to run without DEP you need to do the
following in W2k3 SP1: Right click “My Computer” then
"Properties". Click the “Advanced” tab then click the
"Settings" button under the “Performance” section. Click on
the “Data Execution Prevention” tab and then click the radio
button “Turn on DEP for all programs and services except
those I select”. Then click the “Add” button and add your
exe you don"t want stack protection for. That problem was
fun to hunt down.

Hope this helps someone besides me out someday.

phyler


#11

Thanks for pointing to this article :slight_smile:

Strangely enough we haven’t disabled it for pNSClient… :confused:

Luca