On-Call Rotations


#1

I’ve been trying to set up a 3 week on-call rotation through Nagios going off of the official documentation and have been getting stuck. In my timeperiods.cfg file I have the following defined:

define timeperiod{
	timeperiod_name	week1rotation
	alias Week 1 Rotation
	2009-01-26 / 21 00:00-24:00		; Every 21 days (three weeks), starting Monday, Jan 26, 2009
	2009-01-27 / 21 00:00-24:00		; Every third Tuesday starting Jan 27th, 2009
	2009-01-28 / 21 00:00-24:00		; Every third Wednesday starting Jan 28th, 2009
	2009-01-29 / 21 00:00-24:00		; Every third Thursday starting Jan 29th, 2009
	2009-01-30 / 21 00:00-24:00		; Every third Friday starting Jan 30th, 2009
	2009-01-31 / 21 00:00-24:00		; Every third Saturday starting Jan 31st, 2009
	2009-02-01 / 21 00:00-24:00		; Every third Sunday starting Feb 1st, 2009
}

define timeperiod{
	timeperiod_name	week2rotation
	alias Week 2 Rotation
	2009-02-02 / 21 00:00-24:00		; Every 21 days (three weeks), starting Monday, Feb 2nd, 2009
	2009-02-03 / 21 00:00-24:00		; Every third Tuesday starting Feb 3rd, 2009
	2009-02-04 / 21 00:00-24:00		; Every third Wednesday starting Feb 4th, 2009
	2009-02-05 / 21 00:00-24:00		; Every third Thursday starting Feb 5th, 2009
	2009-02-06 / 21 00:00-24:00		; Every third Friday starting Feb 6th, 2009
	2009-02-07 / 21 00:00-24:00		; Every third Saturday starting Feb 7th, 2009
	2009-02-08 / 21 00:00-24:00		; Every third Sunday starting Feb 8th, 2009
}

define timeperiod{
	timeperiod_name	week3rotation
	alias Week 3 Rotation
	2009-02-09 / 21 00:00-24:00		; Every 21 days (three weeks), starting Monday, Feb 9th, 2009
	2009-02-10 / 21 00:00-24:00		; Every third Tuesday starting Feb 10th, 2009
	2009-02-11 / 21 00:00-24:00		; Every third Wednesday starting Feb 11th, 2009
	2009-02-12 / 21 00:00-24:00		; Every third Thursday starting Feb 12th, 2009
	2009-02-13 / 21 00:00-24:00		; Every third Friday starting Feb 13th, 2009
	2009-02-14 / 21 00:00-24:00		; Every third Saturday starting Feb 14th, 2009
	2009-02-15 / 21 00:00-24:00		; Every third Sunday starting Feb 15th, 2009
}

But when I view the config in Nagios itself I see the following:

week1rotation 	Week 1 Rotation
	2009-00-01 / 21	00:00:00 - 24:00:00
	2009--1-31 / 21	00:00:00 - 24:00:00
	2009--1-30 / 21	00:00:00 - 24:00:00
	2009--1-29 / 21	00:00:00 - 24:00:00
	2009--1-28 / 21	00:00:00 - 24:00:00
	2009--1-27 / 21	00:00:00 - 24:00:00
	2009--1-26 / 21	00:00:00 - 24:00:00
week2rotation 	Week 2 Rotation
 	2009-00-08 / 21	00:00:00 - 24:00:00
	2009-00-07 / 21	00:00:00 - 24:00:00
	2009-00-06 / 21	00:00:00 - 24:00:00
	2009-00-05 / 21	00:00:00 - 24:00:00
	2009-00-04 / 21	00:00:00 - 24:00:00
	2009-00-03 / 21	00:00:00 - 24:00:00
	2009-00-02 / 21	00:00:00 - 24:00:00
week3rotation 	Week 3 Rotation
	2009-00-15 / 21	00:00:00 - 24:00:00
	2009-00-14 / 21	00:00:00 - 24:00:00
	2009-00-13 / 21	00:00:00 - 24:00:00
	2009-00-12 / 21	00:00:00 - 24:00:00
	2009-00-11 / 21	00:00:00 - 24:00:00
	2009-00-10 / 21	00:00:00 - 24:00:00
	2009-00-09 / 21	00:00:00 - 24:00:00

I can’t account for anything that would cause the discrepancy in the dates between what is in the config file and what Nagios is showing that loads. Before this week we were going with a standard everyone gets paged time period but we would like for that to change.


#2

The only thing that jumps out for me is that all the errors appear to be for timeperiods where the start date is configured in the future, i.e. the Feb 2009 dates. I’d be inclined to try and ‘backdate’ those by 3 weeks and use a start date that occurs in the past, see if that works.

HTH

/S


#3

Seems like a bug? Weird. Same here. Maybe to upgrade on a latest version, but there is no any update about it in version history.
It looks like it tries shift the timeperiods 2 months earlier. You can report the bug:
nagios-devel_AT_lists.sourceforge.net
replace AT with @


#4

Setting the times to 3 weeks in the past seems to have done the trick. Seems weird that it cares about that but as long as I know that to be the case I’m good with it.