One or more problems


#1

Hi all

I am a first-time Nagios user (2.10) and having trouble getting it running on my Gentoo Linux system. I have followed instructions on daniel.jp/joomla/info/gentoo … s-2.0.html to install and set up various configs.

My problem is that I cannot start up Nagios. I get the following message:

[blockquote][code]Nagios 2.10
Copyright © 1999-2007 Ethan Galstad (http://www.nagios.org)
Last Modified: 10-21-2007
License: GPL

Reading configuration data…

***> One or more problems was encountered while processing the config files…

 Check your configuration file(s) to ensure that they contain valid
 directives and data defintions.  If you are upgrading from a previous
 version of Nagios, you should be aware that some variables/definitions
 may have been removed or modified in this version.  Make sure to read
 the HTML documentation regarding the config files, as well as the
 'Whats New' section to find out what has changed.[/code]

[/blockquote]

Searching on google I see that other people have had similar messages but with something more specific after “reading configuration data” such as a particular file, line number, etc. It’s not being so kind to me. I have no idea as to what the problem is, there is nothing obviously (to me) wrong in the file but as I said, I am new to this, and Nagios isn’t being terribly helpful with its vague complaint about “one or more problems”. Can anybody point me in the right direction please?

nagios.cfg file attached if that helps at all.

many thanks
H


#2

Hi!

well; too bad: I can’t get your attached file … that could have helped a lot :slight_smile:

and too bad also that nagios is not very helpful. Usually, when there’s an error, it just points to the line that causes the difficulty.

Anyway, firstly, you can try the command:
nagios-dir/bin/nagios -v nagios-dir/etc/nagios.cfg
It may be a bit kinder and help you… but I’m not really hopeful on this one!

Anyway, something that may help you:
you should get rid of all your personnalized config files.
ie: try to start nagios with the minimum (1 hostgroup, 1 host, 1 service); just get rid of everything else.

Then, once you get nagios going, add your own config one by one (like 1 host at a time); this will help you troubleshooting the issues.

And if it still doesn’t work, try to post here your first 100 lines of nagios.cfg, and your config files (don’t know the post limit, but I hope it will fit :))


#3

Hi Loose. Thanks for trying to help me, I don’t know what happened to the attached file. I have solved the problem, it was good old file permissions. Gave the nagios user read permissions on the config files and am now getting meaningful error messages about other stuff. Thanks!