Passive Service Checks


#1

Ive having problems trying to get passive service checks working with nagios.

send_nsca is sending the messages to my nagios server fine, though nagios is logging the following in syslog:

Oct 17 15:08:05 nagios nagios: EXTERNAL COMMAND: PROCESS_SERVICE_CHECK_RESULT;workstation1.terdmonk.com;users;1;USERS WARNING - 9 users currently logged in|users=9;5;10;0
Oct 17 15:08:27 nagios nagios: Warning: Message queue contained results for ser
vice ‘users’ on host ‘workstation1.terdmonk.com’. The service could not be
found!

Ive defined a ‘user’ service definition in services.cfg, though im not sure that this is correct.

define service{
use terdmonk-service
host_name workstation1
name users
service_description users
is_volatile 0
check_period 24x7
max_check_attempts 3
normal_check_interval 1
retry_check_interval 1
contact_groups admin
notification_interval 240
notification_period 24x7
notification_options c
check_command “”
}

What have i left out that will get passive service checks working?


#2

host_name and service_description must match EXACTLY. Please read the README file that came with nsca again. Fix your .cfg’s then restart nagios. You may have to disable/enable passive checks after you fix the files, via the web interface.
But at this point, your services.cfg is not right.
passive_checks_enabled 1
check_command service_is_stale
freshness_threshold 1200
check_freshness 1
active_checks_enabled 0
host workstation1.terdmonk.com


#3

Thanks jakkedup!

My problem was the hosts were different between the client and the server.

I owe you a beer next time you’re in Melbourne, Australia. 8)