Perplexed. A helping hand would be nice


#1

I’m setting up a new Nagios/Cacti server for my organization and almost at the finish line. However, I’m running into trouble migrating our serial temperature sensors.

Background:

Server: Dell PowerEdge R610
OS: Debian 5.0
Nagios Version: 3.2

I’m running the check_digitemp.pl from my libexec folder which has no problems running from shell with appropriate arguments .

I can run the script as the nagios or the www-data user without any problems in a shell, however when I invoke it via a command_line it returns the following:

(Return code of 255 is out of bounds)

I’ve been over my syntax in my commands.cfg and host config file and they all seem ok. What am I missing? Any help is greatly appreciated .


#2

Ok, I figured it out. And when I say “I”, I mean my colleage and I.

When I was using the loopback adapter (127.0.0.1) to the monitor the host, it wouldn’t run the loop in the check_digitemp.pl script that pulls the temperature reading from the devices. As soon as I changed the ip address in the .cfg file for the localhost from the loopback to the network address, it worked fine.

I’m not sure why, but it works now.