Problem accessing nagios as www.localhost/nagios/cgi-bin


#1

I have installed nagios2.0rc2 on suse 9
i am able to access my n\w by www.localhost\nagios and do all the stuff.
but when i tries to access it as www.localhost\nagios\cgi-bin
i get following message
Access forbidden!

You don’t have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.

Error 403

192.168.1.163
Fri Feb 10 16:14:41 2006
Apache/2.0.49 (Linux/SuSE)

thanks in advance
reply!!!


#2

Could you try to rewrite those URLs?

Luca
Edited Fri Feb 10 2006, 12:30PM ]


#3

these are
localhost\nagios\ when i am able to access

and it is
localhost/nagios/cgi-bin/

when i get this error

Access forbidden!

You don’t have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.

Error 403

192.168.1.163
Fri Feb 10 16:14:41 2006
Apache/2.0.49 (Linux/SuSE)


#4

did you folow th einstructions correctly as far as the cgi-bin configuration and permissions are involved?
Looks like the apache user hasn’t been added to the nagcmd group… could this be?

Luca


#5

[quote=“dinesh”]t
localhost/nagios/cgi-bin/

when i get this error

Access forbidden!
[/quote]

You don’t access cgi-bin directly. Why have you even attempted to access that directory, I don’t know.
This is not even a problem. You have no problem that I can see. Mine works the exact same way,


#6

jakkedup is right (where’s the news :smiley: )
same here… cgi-bin isn’t accessible and shouldn’t be… you should be accessing the cgi’s by the main interface no directly.

Luca


#7

ok
i thought these are the two ways to access nagios web interface.

thanks.