Problem accessing Web interface..may be the httpd.conf file


#1

NAGIOS on FC 4…

I cant access …/mymachine/nagios/ as well as /mymachine/nagios/cgi-bin/

Following error::

Forbidden

You don’t have permission to access /nagios/cgi-bin/ on this server.
Apache/2.0.54 (Fedora) Server at apache Port 80

1.When i restart my apache …i get 2 warnings…

Starting httpd: [Wed Jan 11 11:11:27 2006] [warn] The ScriptAlias directive in /etc/httpd/conf/httpd.conf at line 1048 will probably never match because it overlaps an earlier ScriptAlias.
[Wed Jan 11 11:11:27 2006] [warn] The Alias directive in /etc/httpd/conf/httpd.conf at line 1057 will probably never match because it overlaps an earlier Alias.

This is my httpd.conf file changes…

ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin
1049
1050 <Directory “/usr/local/nagios/sbin”>
1051 Options ExecCGI
1052 AllowOverride AuthConfig
1053 Order allow,deny
1054 Allow from all
1055
1056
1057 Alias /nagios/ /usr/local/nagios/share
1058
1059 <Directory “/usr/local/nagios/share”>
1060 Options None
1061 AllowOverride AuthConfig
1062 Order allow,deny
1063 Allow from all
1064

  1. Also when i checked my error_log file … i get the followin line dicy …

[Wed Jan 11 11:11:39 2006] [error] [client 192.168.1.132] client denied by server configuration: /usr/share/nagios/
590 [Wed Jan 11 11:11:39 2006] [error] [client 192.168.1.132] File does not exist: /var/www/html/favicon.ico
591 [Wed Jan 11 11:11:43 2006] [error] [client 192.168.1.132] client denied by server configuration: /usr/lib/nagios/cgi/ 592 [Wed Jan 11 11:11:43 2006] [error] [client 192.168.1.132] File does not exist: /var/www/html/favicon.ico

i hav the .htaccess file in /sbin and /share directory
Both hav nagios as owners…

ALso both /local/nagios/ ans /local/nagios/cgi-bin/ hav nagios as users…

Still i don hav the permission to /my-machine/nagios/ as we;; as /nagios/cgi-bin/

PLEASE HELP !!
Stuck since 2 days…


#2

make sure you follow the instructons in the doc (the part regarding setting up the web interface)
And check you don’t have SELinux enabled.

Luca

PS: About the nonmatching directives… you are defining the Script alias outside of the directory tags… so it applies for the whole server and not only for the virtualhost/directory
Edited Tue Jan 10 2006, 05:13PM ]


#3

i changes my Alias path to /usr/share/Nagios/
and now i don get the 403 error on /mylocalmachine/nagios/

Also disabled SELINUX …
Thanx