Problem checking mssql


#1

Hi,

when I check a server with a bbdd mssql by command in my ubuntu 8.04 all is working fine:

sudo ./check_nt -H srvsql -v SERVICESTATE -d SHOWALL -l MSSQL\$FENIX -s holahola -p 12489 MSSQL$FENIX: Started

As you can see, I use a “” before the “$” symbol.
But when I run this command from inside the windows cfg I always got an error:

define service{ use generic-service host_name srvsql service_description SQL Server check_command check_nt!SERVICESTATE! -d SHOWALL -l MSSQL\$FENIX }

I mean, there is a difference in how Nagios and linux understand the characters “$”.

So, how could I write fine this inside my windows.cfg??

Thank you!


#2

some people have had success by escaping the $ with another $… like
check_command check_nt!SERVICESTATE! -d SHOWALL -l MSSQL$$FENIX


#3

I use NSClient++ and just use CheckServiceState CheckAll. This will report on services that are set to automatic and are not running.


#4

I have used several options:

-l MSSQL$$FENIX
-l MSSQL$$FENIX
-l MSSQL$$FENIX
-l MSSQL$$\FENIX
-l MSSQL$\FENIX
-l MSSQL$FENIX
-l MSSQL\FENIX

No one of them works :frowning:

Thank you for your help.


#5

-l MSSQL\$$FENIX

??


#6

That works fine!!!

Thank you!!!


#7

The slick part about using NSClient++ is that you can also check perfmon counters and graph them with PNP.

Your DBAs will love you if you do. :slight_smile: