Problem on installing plugin 1.4 on solaris 10


#1

Hi,
i try to install nagios plugin 1.4 on solaris 10.
when i run ./configure it doesnt show anything
but when i run make
it shows

make all-recursive
make[1]: Entering directory /export/local/nagios/nagios-plugins-1.4' Making all in intl make[2]: Entering directory/export/local/nagios/nagios-plugins-1.4/intl’
make[2]: Nothing to be done for all'. make[2]: Leaving directory/export/local/nagios/nagios-plugins-1.4/intl’
Making all in lib
make[2]: Entering directory /export/local/nagios/nagios-plugins-1.4/lib' make all-am make[3]: Entering directory/export/local/nagios/nagios-plugins-1.4/lib’
make[3]: Nothing to be done for all-am'. make[3]: Leaving directory/export/local/nagios/nagios-plugins-1.4/lib’
make[2]: Leaving directory /export/local/nagios/nagios-plugins-1.4/lib' Making all in plugins make[2]: Entering directory/export/local/nagios/nagios-plugins-1.4/plugins’
gcc -g -O2 -L. -o check_icmp check_icmp.o …/intl/libintl.a -lgen -lsocket
Undefined first referenced
symbol in file
gethostbyname check_icmp.o (symbol belongs to implicit dependency /usr/lib/libnsl.so.1)
inet_addr check_icmp.o (symbol belongs to implicit dependency /usr/lib/libnsl.so.1)
inet_ntoa check_icmp.o (symbol belongs to implicit dependency /usr/lib/libnsl.so.1)
ld: fatal: Symbol referencing errors. No output written to check_icmp
collect2: ld returned 1 exit status
make[2]: *** [check_icmp] Error 1
make[2]: Leaving directory /export/local/nagios/nagios-plugins-1.4/plugins' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory/export/local/nagios/nagios-plugins-1.4’
make: *** [all] Error 2

what is the problem
what should i do now
Thankyou