Problem with check_command in Nagios 3.0


#1

Hi all,
maybe there’s a problem with Nagios 3.0b7. I’ve this host templates:

define host{
name generic-host ; The name of this host template
notifications_enabled 1 ; Host notifications are enabled
event_handler_enabled 1 ; Host event handler is enabled
flap_detection_enabled 1 ; Flap detection is enabled
failure_prediction_enabled 1 ; Failure prediction is enabled
process_perf_data 1 ; Process performance data
retain_status_information 1 ; Retain status information across program restarts
retain_nonstatus_information 1 ; Retain non-status information across program restarts
register 0 ; DONT REGISTER THIS DEFINITION - ITS NOT A REAL HOST, JUST A TEMPLATE!
}

Virtual means is not real, just a container for services that must be aggregated (e.g. cluster services)

define host{
name virtual-host ; The name of this host template
use generic-host ; Name of host template to use
check_period 24x7 ; By default, hosts are checked round the clock
max_check_attempts 1 ;
check_interval 0 ; Never check at regular intervals
notification_interval 0 ;
notification_period 24x7 ;
notification_options n ;
register 0 ; DONT REGISTER THIS DEFINITION - ITS NOT A REAL HOST, JUST A TEMPLATE!
}

As stated in Nagios documentation (either 2.0 or 3.0), when no “check_command” is defined, host should NEVER be checked:
"If you leave this argument blank, the host will not be checked - Nagios will
always assume the host is up. This is useful if you are monitoring
printers or other devices that are frequently turned off."
Whit Nagios 2.8 this is correct and the host is always UP. With Nagios 3, instead, host remain gray and with PENDING status. Is it a bug?

Thanks,
Luigi


#2

I’m seeing this same behavior. I just upgraded to 3.0 today. Now all my passive hosts remain in a pending state.