Problem with notifications


#1

I’ve noticed a strange problem with my nagios 1.2 install to do with who is getting alerts for what. One of the servers is configured to send host and service alerts to x@mydomain.com isn’t getting the alerts, I am and about 4 other people who aren’t even in the contact group for that server are getting the alerts too. No where in the configs are these 4 other people listed for that host. They do exist for other hosts but not this one. Anybody have any idea why this is happening? I can provide more info if something specific is neeed.
Edited ]


#2

what is nagios reporting in the notifications page about who is being notified?

Luca


#3

It is reporting my address and a group that should be getting alerts and the other addresses that should not be getting alerts. Nowhere does it show one of the groups that should be getting the alerts. Do you think it’s possible that putting a default contact group in a template might be screwing with it? Mind you, none of the names that shouldn’t be getting alerts are in any of the groups that should be.

And now that I am looking at it, it seems that alerts are being mailed to all the same people regardless of whether they were to receive alerts on it or not. Very strange.

I am using nagat for config too. I don’t think that would make it broken but you never know.

Edited Thu May 26 2005, 08:57AM ]


#4

have you tried looking directly at the contactgroups.cfg and contacts.cfg files to see if there’s something out of place?

Luca


#5

Yes, I have and everything looks like it should be working. The right contacts/contactgroups are listed for each service and yet the same 5 or so people are the only ones getting the alerts.

I may have to just bite it and delete all the contacts/groups and remove them from the 150 odd services and redo them all if I can’t figure out why it’s pooched. Ugh.
Edited Fri May 27 2005, 06:06AM ]


#6

I’d like to help, but you are using nagat, and I’m not comfortable with these gui’s for setting up the config files. My suggestion is to do it the old fashioned way, and setup the config files without a gui.