Problem with setting up web interface


#1

Hi,

I had problem with setting up web interface.
OS: Redhat Linux 9
Nagios version 2.10
Nagios Plugins 1.4.11

When i tried to follow the steps in Nagios Documentation, i am not able to view nagios page.
As said in the documentation, i added the following script in the httpd.conf file.

ScriptAlias /nagios/cgi-bin /usr/local/nagios/sbin
<Directory “/usr/local/nagios/sbin”>
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user

Alias /nagios /usr/local/nagios/share
<Directory “/usr/local/nagios/share”>
Options None
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user

And then, i went to cgi.cfg and changed use_authentication value from 0 to 1

Then i went to command promt and run this command to create a password for the nagiosadmin.
htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin

I entered password and when asked to retype,i typed my password again.

A password file is created in the usr/local/nagios/etc.

Then, i restared the apache webserver, by making use of this command.

/etc/rc.d/init.d/httpd restart

Now, when i tried to point to my browser using ‘http://localhost/nagios

It is asking for username and password.
Even though i type the correct username and password, i am not able to see the nagios page.

What are the other changes that i need to do, inorder to set the web interface?
I placed the scriptalias and alias befor the default script alias command available in the configuration file.

Kindly help me in this regard.


#2

A quick answer, just to make sure:
could you try to go to:
localhost/nagios) ?

It may work better (if not, please, post again and I/we will try to help you further ^^)


#3

i tried that but still the same problem.


#4

Without knowing exactly what it is doing, I may have had this same problem. Try this - it worked for me: localhost/nagios/index.html

On mine, I’m guessing it’s because of the default index setting in Apache. Works perfectly now.


#5

Thank you very much for replying. But, my problem is not yet solved.


#6

anything pertinent in the apache error log? (normally /var/log/httpd/error_log)