Problems Starting on CentOS3


#1

Hello,

I have tried the rpms for 1.2 and the 2.0 beta. My latest is the 1.2 tar I compiled in. All with the same result:

[root@webserver root]# /etc/init.d/nagios start
Starting network monitor: nagios
CONFIG ERROR! Start aborted. Check your Nagios configuration.

Please take no offense, but could it be anymore vague? There is no specifics on which config file, where the error occurs and I could not find any logs that displayed this info. Is there anyway to tell where the error is?

Thanks in advance.

Jim


#2

[quote=“bpoppa”]
Starting network monitor: nagios
CONFIG ERROR! Start aborted. Check your Nagios configuration.

Please take no offense, but could it be anymore vague? Is there anyway to tell where the error is?
Jim[/quote]

Did you try nagios.sourceforge.net/docs/1_0/
The docs are quite clear on how to check the configs. If you haven’t read the docs, please do so. If you have further trouble after that, let us know. The error you got sounds self explanatory. Check your nagios configuration. One of the .cfg files is not correct, and if you had tested the nagios installation per the docs, it would tell you exactly what config file is broken.

So, test the nagios installation by using the proper command line and option switch and it will tell you what is broken.


#3

CentOS is a RH derivate… could it be a Secure Linux issue?

Luca


#4

Well, the error message was from nagios saying to check his cfg files. So he later could have an issue, but at this point, he hasn’t ran the test on the cfg files to find out which one is broken.
I am purposely not telling him exactly the command line to run, since it’s in the docs, and everyone should read the docs at least one time.