Process with space in front of name


#1

Hi over there…

I need your help. I’ve seen a lot of topics talking about process names with space in the name, but not in front of it.

I have to monitor à windows service with nsclient, that has a space in front of the name.

" update.exe".

Does anybody know how to do it?

I’ve tried with double quote (""), with simple quote (’’) but nothing worked…

Thanks for your help…

NoSiL


#2

Hmm, did you try by full path or just include the trailing ‘’?

Perhaps it’s not a space but another unprintable character?


#3

Hi mmestnik,

Thank you for your comment.

Nagios is comparing the name from the task manager, so the full path would not work for this.

It could be that it is not a blank character, but I don’t know which one.

It’s really annoying, 'coz I really need to monitor these process…

Any further help would be appreciated…

Thanks

NoSiL


#4

I’ve had success with the RDP client provided with samba 3.3.0 and above. There was a registry key that needed to be disabled so Samba could use an older authentication method, but temporarily just to probe for the true service name should be OK.

I used RDP client successfully in Event Handlers to restart ColdFusion and Java.

Another option might be to get the same information via SNMP, Ive found %90 of what is in the task manager is exposed by SNMP Informant.