RADIUS Plugin ... HELP!


Hey guys, I am at my witts end with this plugin, I have had nothing but problems with it. Heres the skinny

I am running nagios 1.2 on fedora core 2 linux. I have successfully compiled the plugin along with all the deps (radiusclient-0.3.1-1 and associated devel package)

I can execute the plugin from the shell and it works, authenticates to the radius and all is well. The syntax I am using in the shell and both the checkcommands.cfg is

/check_radius -H(hostaddress) -F /usr/etc/radiusclient/radiusclient.conf -u(username) -p(password) -t10

Works great in the shell, however when running the plugin from nagios, it returns the error “config file error”

Please Help!


/check_radius -H(hostaddress) -F /usr/etc/radiusclient/radiusclient.conf -u(username) -p(password) -t10

if this is in the command file you are probably missing s $USER1$ in front of it :wink:

if it isn’t please post the command definition :slight_smile:



i have tried with and without the $USER1$ i have even tried with the full path of the check_radius plugin


$USER1$ defines your nagios plugins default location so it is needed. $HOSTADDRESS$ is passed by Nagios itself. Are you passing username and password as parameters or are they defined in the command definition?



I am passing username and pass params in the command definition, the checkcommands.cfg for this service read like so:
$USER1$/check_radius -H $HOSTADDRESS$ -F /usr/etc/radiusclient/radiusclient.conf -u(username) -p(password) -t10
same “config file error” in nagios

The config file error is referring to the radiusclient.conf im almost sure of it, I dont think that this has anything to do with the checkcommands.cfg syntax


I feel i need to clairify, nagios will start up and check all of my other defined services just fine, however after nagios attempts to check this service an orange ‘unknown’ tag is given to this service, service detail shows ‘config file error’


try this way…
$USER1$/check_radius -H $HOSTADDRESS$ -F /usr/etc/radiusclient/radiusclient.conf -u $ARG1$ -p $ARG2$ -t10

as command use:

Ciao, Luca


k, same thing, no change still same “config file error”


nagios is ran as user nagios. That user most likely has no access to /usr/etc/…

Try copiing the raius.conf to /usr/local/nagios/etc and give it same permissions as the rest of the etc files.


Yes, in /var/log/messages i found permisson denied errors trying to access the radiusclient.conf, the plugin is working!!
Thanks for all of your help


wooohoo, I’m bad. hehe
i get 10 wrong, and 1 correct, and i’m all giddy. haha